Error Code 502 - Expo via Android Studio

Hi guys !!

I keep racking my brain, with Expo…
All worked fine, and suddenly not that all. I got a 502 error (screenshots).
Package.json :

  "dependencies": {
    "@expo/samples": "^2.0.2",
    "@expo/vector-icons": "^5.2.0",
    "expo": "^20.0.0",
    "native-base": "^2.3.1",
    "react": "16.0.0-alpha.12",
    "react-native": "",
    "react-navigation": "^1.0.0-beta.12"

Server is up and working fine --> I got “web result” on PC (switch exp:// to http:// protocol --> [my.local.ip.address]:19000).
My Android Emulator (Android Studio v.2.2.3 - API 25 - 7.1.1) got an Internet connection, and the same result than PC :

  • Chrome
  • Tape in the URL bar [my.local.ip.address]:19000).

I try to set REACT_NATIVE_PACKAGER_HOSTNAME=my.local.ip.address. But there is no change.
I try to reset the Expo cache too… but no change.

Windows 10 - Android Studio API lvl 25 - Expo v20.0

Please help me, I don’t know what to do…

If you have any question, don’t hesitate.


1 Like

Sorry about the poor error message here. Can you post a screenshot of that redbox after scrolling up? The actual error text doesn’t appear to be visible.


Unfortunately, I have delete my screenshots…

But this kind of error message was display, “Connection refused, the computer refused the connexion.” (Firewall open)

Best regards,

1 Like

Even i m facing the same issue on redhat linux center os tried every possible solution but didnt figured out a solution so anyone suggesst a proper solution

1 Like

I’m also getting the same error on Windows 10. The issue seems to be the expo client connecting through the tunnel, it’s actually possible to visit the URL in a web browser on my phone and see the JSON.

1 Like

+1 here using linux mint

1 Like

worked in linux too:

  1. open this file under root sudo nano /etc/sysctl.conf

  2. then add these two lines:

  1. save: ctrl + x

  2. and reboot