Error building iOS App

Hi! We’ve been getting the build status “[exp] iOS: There was an error with this build.” after trying to build our standalone iOS app and can’t quite figure out why.

More detailed error logs would be greatly appreciated, but nonetheless this is out build ID:

We’ve tried letting expo generate the certs and specifying them ourselves with no luck and authentication seems to be right.

Thanks in advance

hi @beyondx

So sorry for the trouble.

I looked through the logs of the builder and I’m not totally sure what the problem was but I saw a few things that looked like this that seem suspicious to me:

Warning: Output file suffix should be jpg
Warning: Output file suffix should be jpg
<CGColor 0x7fbac8c076f0> [<CGColorSpace 0x7fbac8c04110> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )

For all your app icons, etc., can you try the following?

  1. convert the image to png and give it a .png suffix. double check it’s not one image format with the extension of another
  2. make sure the image matches our recommended dimensions – this is often the cause of problems although its usually logged as such.

If those don’t work then try this maybe:
3. re-encode the image with imagemagick or maybe run it through to get great compression. think there could be something wrong with an unsupported color profile

That’s my best guess. Can you try that and let me know if it solves the problem?

Thanks and sorry for the trouble.

Yep, it seemed to be an issue with the images. We tried a couple things with them so not sure what exactly fixed them, but builds are working now.