EAS cli 0.18.0 - Android remote credentials not copied over from classic

Hi,
Since eas-cli 0.18.0 today, I can’t use Android credentials.
When I try eas build --platform all --non-interactive, I’m getting

Error: Generating a new Keystore is not supported in --non-interactive mode

After the Using remote Android credentials (Expo server) step.
Please help.

1+, also getting the same error with my Github Actions.

If you run build without non interactive flag you will be asked if you want to copy credentials from classic builds to eas builds, until now the same set of credentials were used for both build services

Or you can download classic credentials using expo credentials:manager and upload them using eas credentials

2 Likes

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.