EAS Build fails after files upload (Experience with id '***' does not exist.)

Whenever I run EAS Build on a particular account, it always fails after file uploads.

✔ Using remote Android credentials (Expo server)
✔ Using Keystore from configuration: Build Credentials <xxxxxxx> (default)

Compressing project files and uploading to EAS Build. Learn more
✔ Compressed project files 3s (86.7 MB)
✔ Uploaded to EAS 24s
Build request failed. Make sure you are using the latest eas-cli version. If the problem persists, report the issue.
    CombinedError: [GraphQL] Experience with id '74410bc8-69c5-43d0-b541-307c89edd859' does not exist.
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

I have tried changing the organization, re-creating the project and changing the slug, but I get the same error. The problem did not occur when I build with another expo account (not even belonging to the organization).

  • Managed Workflow
  • eas-cli version: 2.1.0

hi there! can you run eas project:info and share the output?

@brents Thanks for replying.

I couldn’t get the information because an error occurred.

> eas project:info
CombinedError: [GraphQL] Experience with id '74410bc8-69c5-43d0-b541-307c89edd859' does not exist.

Instead, I will give you the Project ID that was on the project page.

67010dab-ab74-4298-9bd7-cc87c0c5a0a0

you may need to change the project id field in your app.json under extra.eas.projectId - it appears to somehow be set to an incorrect value

1 Like

Problem solved!

I forgot to change extra.eas.projectId in app.json after I recreated the project in expo.dev :sweat:

Thanks a lot!

3 Likes

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.