eas build project failed

Hi, I’ve been failing builds recently (eas build-p android --profile test), it’s been days and I’ve tried many ways and it’s still failing. My SDK is version 44,This is my error message:

Loaded "env" configuration for the "test" profile: AOTTO_ENV. Learn more: https://docs.expo.dev/build-reference/variables/
✔ Using remote Android credentials (Expo server)

Compressing project files and uploading to EAS Build. Learn more: https://expo.fyi/eas-build-archive
✖ Uploading to EAS Build (128 KB / 789 KB)
Failed to upload the project tarball to EAS Build

Reason: request to https://storage.googleapis.com/turtle-v2-projects/production/a0c95d92-3783-4444-8f4e-46f88bac112b/cf5482c6-9733-473f-9a0e-62ab0fb08f11?X-Goog-Algorithm=GOOG4-RSA-SHA256&X-Goog-Credential=www-production%40exponentjs.iam.gserviceaccount.com%2F20230809%2Fauto%2Fstorage%2Fgoog4_request&X-Goog-Date=20230809T002232Z&X-Goog-Expires=3601&X-Goog-SignedHeaders=host%3Bx-goog-content-length-range&X-Goog-Signature=941ea8a9ee3a6467188411f56030ca34840dd08b6e65011298b4e6717466da95d235fea85d996502da769a18c1b3fff8f9e120e1aec03f15c2e04e4eba02055548b2edbb4ae2e53826541a84f27971bc9ef3bc7e90a101ddba4fb47dafba0d16686a9b8a0061c88488726abe889028e5df2ee6311c0529c6faf1f5b3646e129c5024b48d858bb0f83900dd98efcbd0748a164be214bb831758147963f09f99a213bcecaf120556cf3b89dd16fc7779f1a722f5dddf67674cb50978d47e5501b9e4047a9026c36bcf870e1eba79138f3161f9d8ff6d8e9e84f9840c6af389220e94140ca01f7bfc7ff716d7f3f56551a22d02fc1f1eed5eee67df83565bf0a23b failed, reason: read ECONNRESET
    Error: build command failed.

please update to the latest eas-cli and let us know if that resolves it

Thank you for your reply. My eas-cli is the latest version, but this problem still exists

 eas --version
 eas-cli/4.1.1 win32-x64 node-v16.17.0

Hi @puxuanhe, there is a new patch eas-cli@4.1.2. Can you please update to that and re-check?

Hi @amanhimself ,I installed it using the command and still got version 4.1.1,However, it shows that the latest available version is 4.1.2,I tried a global uninstall and reinstall and got 4.1.1 as well

npm install -g eas-cli

eas --version
eas-cli/4.1.1 win32-x64 node-v16.17.0

I tried to install the package using the following command, but it seems that this version is not available

npm install -g eas-cli@4.1.2

npm ERR! code ETARGET
npm ERR! notarget No matching version found for eas-cli@4.1.2.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.

I’ve tried to pack a lot these days, and I’ve had some success with it, but it’s only rare. Sometimes it doesn’t work once in dozens of times.

I still have this problem

I have the same problem,have resolved?

this may indicate that there is an issue with your internet connection. make sure that you are able to access google cloud from your location

1 Like

I still exists the question, I think I should not network connection problem. Since the last time I tried to create a project with expo SDK49, I upgraded the eas-cli at that time, and the SDK44.0 package I built before kept failing for no reason, now I have the latest eas-cli…

where are you based out of? can you reproduce this on a different network?

also, you can work around issues with your network by triggering builds from github or another similar service. with github, you can either use a github action or link your github repo