Eas build fails because of uploading

Eas build is failing just now, I did a build three days ago and was fine, but now it crashes and just says this:

eas build --platform all --clear-cache

✔ Using remote Android credentials (Expo server)
✔ Using Keystore from configuration: Build Credentials NvPzvUNGBF (default)

Compressing project files and uploading to EAS Build. Learn more: https://expo.fyi/eas-build-archive
✖ Uploading to EAS Build (128 KB / 4.3 MB)
    FetchError: request to https://storage.googleapis.com/turtle-v2-projects/production/029beda7-e8c7-4aaa-b6cf-c0fda4e73d30/3ff59d0e-ebc3-4399-90f3-9d913c1?X-  
    f3c927f1cff757d662306022de3dfc912680002aa6ab5702c56bea14061f671ab7e8fba27b25648462997091e5e771609fa048e08be81e26e2e3a66564ca4a0d7f1d9be658560fbe62edf3b402 failed, reason:      
    self-signed certificate

If your Android or iOS build is failing- make sure you do your own research on the error message first before posting (this will give you a better understanding, and you might even find that someone else has already solved the issue!) It is not up to the Expo team to debug your project or build.

In your post, please share:

  • Whether you are bare or managed workflow: managed
  • Your eas-cli version: eas-cli/3.3.2 win32-x64 node-v18.12.1
  • What you have tried so far: rebuilding, set NODE_TLS_REJECT_UNAUTHORIZED=0

I am experiencing the same issue - 9 of our deployment pipelines failed today at the EAS upload stage when attempting to upload iOS builds:

CombinedError: [Network] upstream connect error or disconnect/reset before
     headers. reset reason: connection termination
error Command failed with exit code 1.

Note that some of our pipelines (with the same pipeline code) are successful.

Using eas-cli@3.1.1