EAS build failed on iOS - undefined iCloudContainerEnvironment


Our application is using expo-document-picker.

We are facing this warning when starting a build on iOS, but the app works (even the document selector feature).

» ios: expo-document-picker: Cannot configure iOS entitlements because neither the appleTeamId property, nor the environment variable EXPO_APPLE_TEAM_ID were defined.

In order to avoid this warning, we have found out that we can properly configure the document picker by adding the following declaration in our app.config.js:

plugins: [
  ['expo-document-picker', { appleTeamId: 'XXXX' }]

Unfortunately, doing that breaks the eas build on iOS during the fastlane step:

error: exportArchive: exportOptionsPlist error for key "iCloudContainerEnvironment": expected one of {Development, Production}, but no value was provided
Error Domain=IDEFoundationErrorDomain Code=1 "exportOptionsPlist error for key "iCloudContainerEnvironment": expected one of {Development, Production}, but no value was provided" UserInfo={NSLocalizedDescription=exportOptionsPlist error for key "iCloudContainerEnvironment": expected one of {Development, Production}, but no value was provided}

FYI, we are using the managed workflow with expo 44.0.0 and eas-cli 0.45.1.

Thanks in advance for your help!

Could someone help about this warning please?

Hi, I had the same error, but when I did this

plugins: [
  ['expo-document-picker', { appleTeamId: 'XXXX' }]

it worked. I would advise you to downgrade your expo to expo 43.0.2

we released an update to expo-document-picker to pass this value through properly to the plugin - [document-picker][ios] pass iCloudContainerEnvironment to plugin by wkozyra95 · Pull Request #15774 · expo/expo · GitHub

update to the latest version on sdk 44 to fix it, you can do this with expo install expo-document-picker

1 Like

Thanks for your reply. I tried with expo-document-picker 10.1.1 and 10.1.2 but without success, still got the same error. Am I missing something?

Hey, still blocked by this issue. :frowning:
Could this warning be ignored?

It seems to work using 10.1.3 :tada:

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.