EAS build fails after upload (iOS)

Hi everyone,
I’ve just tried EAS build on a bare workflow, everything works flawlessly on Android.
However on iOS just after the upload completes it returns ReferenceError: MARKETING_VERSION is not defined.
All steps before that complete normally.
The variable MARKETING_VERSION is well defined in the xcode project file and referenced by the Bundle version string (short) property in the info.plist.


  "build": {
    "release": {},
    "development": {
      "distribution": "internal",
      "android": {
        "gradleCommand": ":app:assembleDebug"
      "ios": {
        "buildConfiguration": "Debug"

expo diagnostics:

  Expo CLI 3.27.13 environment info:
      OS: macOS 11.4
      Shell: 5.8 - /bin/zsh
      Node: 16.4.0 - /usr/local/bin/node
      Yarn: 1.22.10 - /usr/local/bin/yarn
      npm: 7.18.1 - /usr/local/bin/npm
      CocoaPods: 1.10.1 - /usr/local/bin/pod
      iOS SDK:
        Platforms: iOS 14.5, DriverKit 20.4, macOS 11.3, tvOS 14.5, watchOS 7.4
      Android SDK:
        Android NDK: 23.0.7123448-beta1
      Android Studio: 4.1 AI-201.8743.12.41.6953283
      Xcode: 12.5/12E262 - /usr/bin/xcodebuild
      expo: ^38.0.8 => 38.0.11
      react: ^17.0.1 => 17.0.1
      react-dom: 16.11.0 => 16.11.0
      react-native: ^0.64.0 => 0.64.0
      react-native-web: ~0.11.7 => 0.11.7
      expo-cli: 3.27.13
    Expo Workflow: bare

are you using the latest eas-cli? i can see that your expo-cli version is very out of date

eas-cli version 0.22.4.
Does the expo-cli version matter since I ejected ?

it shouldn’t matter, no, but i thought it might have hinted at your cli upgrade hygiene habits :wink:

any chance you can share a reproducible example? it’s not clear what might be going on here. adding me to the project on github would also be fine – brentvatne on github

I invited you to the project :wink:

thanks! i found the root cause and will roll out the fix soon: [eas-cli] Pass through build settings metadata context to app version resolver by brentvatne · Pull Request #550 · expo/eas-cli · GitHub

released in eas-cli@0.23.0

Problem solved with eas-cli@0.23.0, thanks a lot !