Crash after build ( eas build ) android

Hi everyone, I did eas build for android and without testing builded file on real device or emulator i uploaded it to play market. ( in development everything works well ) but it turns out expo throws exception in build file.
I saw that error about expo-publish and just hour ago i did expo-publish and then eas build and this time i converted aab file to apk ( with bundletool ) and installed in real device, got the same error again.

please share more information about your project. it appears to be misconfigured in some way. If it’s a bare project then debug locally by doing a release build

It is managed workflow. Also i have checked if i publish project i can scan and open app with iPhone but in android app crashes. What config files i have to share ?

you should look at your crash logs for more information, also see this: Debugging - Expo Documentation

Logs from adb logcat , otherwise i dont know how to debug ((

there is an error message about your updates url being missing. can you send a link to your build details page? also share output of running expo diagnostics

expo diagnostics
Expo CLI 4.9.1 environment info:
System:
OS: Windows 10 10.0.19043
Binaries:
Node: 14.17.4 - C:\Program Files\nodejs\node.EXE
Yarn: 1.22.11 - C:\Program Files\nodejs\yarn.CMD
npm: 6.14.14 - C:\Program Files\nodejs\npm.CMD
IDEs:
Android Studio: Version 4.2.0.0 AI-202.7660.26.42.7351085
npmPackages:
expo: ^42.0.0 => 42.0.0
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-42.0.0.tar.gz => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
Expo Workflow: managed

Couldn’t find build details page.

what do you mean you can’t find build details page? it should just be there under builds on expo.io

oh sorry i thought build details its something like data from cli xD, here is my link to details Build Details — 0f1aeffb-f71c-48b8-8c21-eebbc161d6a5 — @mirik/Bidbazaar — Expo

so you are seeing the above error from adb logcat when running the build from that page?

Yes , i have built multiple times ( with eas , with expo , direcly apk format ) and every time i have faced with error.

Also tried to uninstall sentry , expo-updates , expo-devices and other modules which is sentry depends. Didn’t help. Even when i am doing expo-publish android app crashes on expo scan. ( Iphone works well with published app )

can you share me a link to a build of an apk on eas build?

notbrent, can i add you to access list of github repo also , just check ?

with eas build Build Details — 789d5788-6d74-415e-b2fd-dfbb73aca3ca — @mirik/bidbazaar — Expo

that is an aab not an apk :slight_smile: sure, add me on github: brentvatne - although i’m not sure this will be too helpful

edit: nevermind aab is fine, i just did a manifest dump and confirmed the error message matches what i’m seeing here. i’d be interested in seeing your github repo

Thanks, i will be very thankful, i invited you.

it looks like there might be some problems when compiling the bundle with hermes - we’ll have to investigate why the build appeared to succeed here when it shouldn’t have. noticed these errors:

if you try to run this locally in dev client, you will also see this:

your app uses features that aren’t supported by the version of hermes used here. you should disable it

Okay, thank you. I will disable now.

Yes, it worked. Thank you! But app bundle got +10mb to size )))).

Edit: Hmm, it worked with expo publish ( scanning with qr-code ) but built (with eas Build Details — 0a82a617-369e-4279-a6f4-6a4e7daa41c2 — @mirik/Bidbazaar — Expo) aab file throws same exception on physycal device ( first screen ). Hermes disabled.
What i did after your answer ( steb by step )

  1. removed jsEngine from app.json
  2. rebuilt with eas an aab file
  3. published with expo and tested with physycal device ( it worked )
  4. converted aab file to apk (with bundletool) and installed on emulator - crashed
  5. To be sure, i uploaded to playstore downloaded aab file and tested in physycal device - crashed with the same error.

and what are the logs from the crash?

Same crash logs.