APK build with EAS crashes on real devices (This project comes from expo classic build)

I have been working with expo build classsic, without problems it generated an .APK file and it opened correctly on a real device. But now, I have tried with EAS build, and everything runs fine (I have followed the EAS build documentation) after configuring the eas.json file and typing the command: eas build -p android --profile "… …”, But when I install on a real device, it crashes after the splash screen is shown, and closes automatically.

Is there a way to see what the error is in a log?
Should I check the dependencies?
Should I remove main from the package.json file?

I used Expo SDK 45.

use the development build first

i have the same problem, no solution so far! i´m trying many ways

Hello friends. I tried installing the APK on emulator inside android Studio, and open the terminal “Logcat” to see the errors when open the app. So then I found that I had to install “react-native-screens”, “react-native-safe-are-of-context” then again build on EAS and finally works. I hope this help you. But something weird is that some characteristics does not works very well on ios.