Can't select blank template after typing $ init my-app

Hello guys please any solution to the error encountered in the image :point_down::point_down:

How do I select the blank template

Please zoom the image to see the error.

Hey @captaineboy, can you share what environment you are running the cli in? It seems to be running in non-interactive mode. To bypass this in the interim, you can run expo init my-app --template blank


1 Like

Thanks @adamjnav I am using visual studio code.

I have been able to correct that problem but I am currently stuck here, do not know the reason for the error​:point_down::point_down:

I am new to app development so please pardon me for these questions😅

Any help on the above issue, still yet to receive any answer from the community.

Please if you know the solution to the above, please comment.


Hi @captaineboy

getaddrinfo is to do with a DNS lookup. So it seems your machine has some sort of DNS or other networking problems.

Are you able to load that URL in a web browser?

1 Like

Alright, just incase someone else has the same problem above👆

The solution is to run it in your ide instead of using got directly.
I ran it on git bash directly so that was the reason for the non-interactive mode error.

The solution I employed was to run it on visual studio code terminal(precisely got bash) and the problem was solved.

Thanks for your contribution @adamjnav

(2)For the second error I guess it had to do with connectivity issue as suggested by @wodin
The problem was solved with good connection

Also for the yarn error seems I didn’t have yarn installed, had to install that and the problem was solved.

Thanks everyone for your contributions.

Happy Coding

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.