Blank screen after Expo publish

I encountered a serious error with expo.

I have developed an app in React Native and, at the time of publication through the *expo publish* command, it correctly generates the address where I can scan the QR code, but, once this is done, on my mobile I see the loading screen of the app but a white screen appears after that.

I can’t do anything, not even see if it generates any errors or not, it stays blank for more than five minutes (then I closed the app).

With npm start the app works perfectly for me, so I don’t know what the problem could be. I have searched around on the Internet but it seems that in very few we have encountered this hitch and, in the few cases where this has happened, I have tried to apply the solutions proposed by other users, but nothing has changed.

I’ve tried to change the settings.json file in the expo folder (from {“dev”: false,“minify”: true} to {“dev”: true,“minify”: false}), but nothing has changed.

I don’t think about reporting my code: first of all I don’t know what to put, as I have no clue as to where the error is and, above all, it would just get in the way.

Hey @edolisso99, I would suggest rolling back your js bundle via expo publish:rollback command. As for the error, it is most likely related to this Common development errors - Expo Documentation

I would suggest going through the changes you’ve made between your last successful publish and the one that caused the blank screen one by one to try to determine what the culprit code is.

Cheers,
Adam

1 Like

Thank you so much @adamjnav!

You saved me a lot of time!

I’ve been struggling the past three days with this error, but, thanks to your suggestion and a stroke of luck, i’ve finally resolved the issue.

In the link suggested by you Common developement errors - Expo Documentation, i’ve runned the command expo start --no-dev --minify, and i went against the error TypeError: (0,u.useState) is not a function. (In ‘(0,u.useState)(!1)’, ‘(0,u.useState)’ is undefined).

i’ve looked for the solution of this issue and, by pure chance, i’ve noticed that in one of my screens I was wrong to import React useState. Instead of importing him from “react”, the IDE generated this code, through the auto-input command:

import { useState } from “react/cjs/react.development”;

Now everything works perfectly.

Thank you so much again, have a nice day!.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.