Build:ios not working on windows - "invalid credentials"

Getting an error with credentials when building to ios.

Error while gathering & validating credentials
[exp] Reason:Invalid credentials, raw:“Invalid username and password combination. Used ‘XXXXX’ as the username.”
[exp] Set EXPO_DEBUG=true in your env to view the stack trace.

I can log in to my apple developer account with the exact same credentials.
Debug mode confirms the credentials I am entering are the same ones I use to log in to my apple developer account.

Things I’ve tried

  1. Read through Invalid Apple credentials for build:ios and tried the fixes
  2. Confirmed credentials are valid
  3. Confirmed password does not contain a space (per thread in 1.)
  4. Confirmed I’ve accepted the latest apple terms by logging in to their site with my developer account
  5. Read every thread under Search results for 'invalid credentials' - Forums
  6. Tried running expo build:ios -c
  7. Tried fresh install of expo and WSL on a different windows machine
  8. Installed and updated expo and expo-cli globally

The password DOES contain a special character

Any ideas?

Running the exact same commands, with the exact same credentials on a fresh ubuntu instance in the cloud worked, however.

Hey @lorgus,

It looks like there might be an issue escaping the password on Windows. I created an issue to track it here: Sorry for the inconvenience!



This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.