Building to ios returns invalid credentials (credentials are valid)

Getting an error with credentials when building to ios.

Error while gathering & validating credentials
[exp] Reason:Invalid credentials, raw:“Invalid username and password combination. Used ‘XXXXX’ as the username.”
[exp] Set EXPO_DEBUG=true in your env to view the stack trace.

I can log in to my apple developer account with the exact same credentials.
Debug mode confirms the credentials I am entering are the same ones I use to log in to my apple developer account.

Things I’ve tried

  1. Read through Invalid Apple credentials for build:ios and tried the fixes
  2. Confirmed credentials are valid
  3. Confirmed password does not contain a space (per thread in 1.)
  4. Confirmed I’ve accepted the latest apple terms by logging in to their site with my developer account

Any other ideas on what may be wrong?

Any ideas? I noticed people had this problem in the past? Maybe something with 2FA?

Hey @lorgus,

Can you try clearing the credentials and re-uploading them to see if that fixes it? You clear the credentials by either expo build:ios -c or exp build:ios -c.



This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.