build:ios failing with no error message

My iOS builds just started failing a few days ago. I’ve revoked and reissued certificates and the profile and it still doesn’t work. Here is an example: It just stops building and freezes here:

Same for me, no changes other than a version bump and JavaScript stuff since I built it last time. Stuck on the exact same step, and when the build has been going for about an hour it is removed from my build-list.

Edit: If it hasn’t been removed yet this is the build:

Hey @ghostops and @pzupan,

Can you let me know what version of expo-cli you are running and if you have a large quantity of assets or abnormally large asset file sizes in your projects?


I’m using expo-cli version 2.6.8. And here are the assets I’m loading:

 _loadResourcesAsync = async () => {
    return Promise.all([
        // This is the font that we are using for our tab bar
        // We include SpaceMono because we use it in HomeScreen.js. Feel free
        // to remove this if you are not using it in your app
        'space-mono': require('./assets/fonts/SpaceMono-Regular.ttf'),

@adamjnav Assets folder is 758KB loading only splash, icon, and 3 font files. Running expo-cli 2.6.14. Thanks in advance!

It turns out with was due to a short service outage we had and should be good to go. If you haven’t tried already, you should be good to build again.

I’m still having the same issue. However, I notice in the build log that there a large number of assets identified in the package. Not sure where they are coming from…

\"configuration_version\\": \\"1\\"\\n}","package":"org.idhra.racingrulesofsailing","permissions":["VIBRATE","NOTIFICATIONS"],"versionCode":17},"bundledAssets":["asset_3a2ba31570920eeb9b1d217cabe58315.ttf","asset_744ce60078c17d86006dd0edabcd59a7.ttf","asset_140c53a7643ea949007aa9a282153849.ttf","asset_6beba7e6834963f7f171d3bdd075c915.ttf","asset_b06871f281fee6b241d60582ae9369b9.ttf","asset_e20945d7c929279ef7a6f1db184a4470.ttf","asset_b2e0fc821c6886fb3940f85a3320003e.ttf","asset_d15c1216957060fac577af6151fb8cfe.ttf","asset_a37b0c01c0baf1888ca812cc0508f6e2.ttf","asset_73b8cff012825060b308d2162f31dbb2.ttf","asset_d2285965fe34b05465047401b8595dd0.ttf","asset_5cdf883b18a5651a29a4d1ef276d2457.ttf","asset_4dbc10fd34db70b75c821f766659cb81.png","asset_80286c9b992fad5b500d5a1f06434b5f.png","asset_84ad3fe438ba116b007697ae568e22de.png","asset_9098f279a79458551f75c67a0f741e7d.png","asset_dfc580f63d59d8ffbe6a62d000388e86.png","asset_25be4da7236d5add94db4c612d243b2c.png","asset_f52efad4d6a123c4c4e09241036b80ed.png","asset_da4303c980b7f993076b634937adaa6b.png","asset_121f3bcfa420e77f48064983d90ea544.png","asset_d37ddbcd08c865194a83f47664629ccd.png","asset_07ff227fc7d39db4d4903e8367fa30e9.png","asset_61b13cb6db14eea1a4e083c331ef816c.png","asset_7d40544b395c5949f4646f5e150fe020.png","asset_cdd04e13d4ec83ff0cd13ec8dabdc341.png","asset_a132ecc4ba5c1517ff83c0fb321bc7fc.png","asset_0ea69b5077e7c4696db85dbcba75b0e1.png","asset_f5b790e2ac193b3d41015edb3551f9b8.png","asset_755fce460f64aed4d3f3ac1a6249ceea.png","asset_004c2bbb035d8d06bb830efc4673c886.png","asset_2327736b3ea09c41abfb69be1221f430.png","asset_51671417ef20e0bbc32f0a2bc6edfa95.png","asset_a7b9dc9de5f8f1fb1afbef917619a5ac.png","asset_4bdd6aad790c6c8370a06876ec7d31e1.png","asset_4b9cf0cc747e3c1abc541befa05b1e37.png","asset_813a0f8a6e53112ede50d46110c3a704.png","asset_9adf57c18894afd6837c6f42550e555a.png","asset_5f3cddea1db254301a533f5790db704f.png","asset_b39b2b41e337c20a916b1e9c3c2c1c58.png","asset_6d6ec35f799a3e7a43370bd8a2d0c50c.png","asset_477e4dc75e3aa980e2712fdbf1e622b7.png","asset_4b088107f015be3f4af74c7894d7bdd7.png","asset_d7a53eb7377202f2f7c3812c5a113535.png","asset_566e65f5a014b2df4e1ded9418412b94.png",...

@adamjnav tried again, but still has the same error. Same for me as for @pzupan, my manifest contains a bunch of image assets but in the assets folder there are only 2 images.

@pzupan Ok I just had a revelation… The assetBundlePatterns in app.json was set to **/*, which means ANY asset in your project folder, no matter if it is in the assets folder or not, will be bundled. I changed my asset bundle path to ./assets/**/* and now it only bundles the assets I use. Hope this fixes it for you as well.

Thanks @ghostops. Setting the assetBundlePattern to “./assets/**/*” worked for me as well.

1 Like

Glad you two were able to get it built. Sorry for the confusion there. Raising a discussion internally about possibly making a change to the default value when creating a new Expo project.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.