expo build:ios fails with no error messages

Please provide the following:

  1. SDK Version: 40
  2. Platforms(Android/iOS/web/all): iOS / Android

expo build:ios fails with no error messages, just the following output

You can press Ctrl+C to exit. It won’t cancel the build, you’ll be able to monitor it at the printed URL.
:heavy_multiplication_x: Build failed.
Standalone build failed!

A build with almost identical code succeeded about 6 hours ago. But now after retrying about 10 times it won’t build. Already tried cleaning certs with expo build:ios -c

BTW the URL for build will not show any data as it says it does not exist yet. The same error with the same output happens for expo build:android

I was able to check the logs by going to my builds link, instead of the direct build link that was provided.
There I found this:

Cleaning up iOS...

7Wed, 30 Dec 2020 15:58:26 GMT

Error: xcrun exited with non-zero code: 1
    at ChildProcess.completionListener (/usr/local/turtle-js/node_modules/@expo/xdl/node_modules/@expo/spawn-async/build/spawnAsync.js:52:23)
    at Object.onceWrapper (events.js:418:26)
    at ChildProcess.emit (events.js:311:20)
    at ChildProcess.EventEmitter.emit (domain.js:482:12)
    at maybeClose (internal/child_process.js:1021:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5)
    at spawnAsync (/usr/local/turtle-js/node_modules/@expo/xdl/node_modules/@expo/spawn-async/build/spawnAsync.js:17:21)
    at spawnAsyncThrowError (/usr/local/turtle-js/node_modules/@expo/xdl/build/detach/ExponentTools.js:201:45)
    at Object.buildAssetArchiveAsync (/usr/local/turtle-js/node_modules/@expo/xdl/build/detach/IosAssetArchive.js:96:51)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)
    at async Object.configureAsync (/usr/local/turtle-js/node_modules/@expo/xdl/build/detach/IosNSBundle.js:719:7)
    at async Object.configureAndCopyArchiveAsync (/usr/local/turtle-js/node_modules/@expo/xdl/build/detach/IosShellApp.js:367:3)
    at async Object.runShellAppBuilder [as default] (/usr/local/turtle-js/build/builders/utils/ios/shellAppBuilder.js:67:12)
    at async Object.buildArchive [as default] (/usr/local/turtle-js/build/builders/ios/archive.js:39:26)
    at async Object.iosBuilder [as ios] (/usr/local/turtle-js/build/builders/ios/index.js:30:13)
    at async build (/usr/local/turtle-js/build/jobManager.js:181:33)
    at async processJob (/usr/local/turtle-js/build/jobManager.js:118:32)
    at async Object.doJob (/usr/local/turtle-js/build/jobManager.js:49:5)
    at async main (/usr/local/turtle-js/build/server.js:66:13)

which seems to be related to icon / splash image format. Will fix this and report back. However, I must say, this process needs to be improved. Too cryptic / convoluted even for experienced devs.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.