[Stuck] Authenticating to Apple Developer Portal...

For some reason, I’m not able to run expo build:ios anymore. It gets stuck on “Authenticating to Apple Developer Portal…”

I’ve been trying to fix this issue for the past 48 hours and I did a lot of research and even tried some of the suggestions. I do have WSL enabled, I also tried to reinstall/update expo-cli, removed node_modules, reinstalled all the packages, but no success. I can log into the Apple Developer Portal with no issues and I don’t have any pending ToS or agreement to accept there.

Do you guys have any other ideas?
Everything was working fine a couple of months ago and I haven’t changed anything since then.


Expo CLI 4.0.13 environment info:
OS: Windows 10 10.0.18363
Node: 12.16.1 - C:\Program Files\NodeJS\node.EXE
Yarn: 1.21.1 - C:\Program Files (x86)\Yarn\bin\yarn.CMD
npm: 6.13.4 - C:\Program Files\NodeJS\npm.CMD
Android Studio: Version AI-193.6911.18.40.6626763
expo: ^39.0.3 => 39.0.3
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-39.0.3.tar.gz => 0.63.2
react-native-web: ~0.13.7 => 0.13.18
react-navigation: ^4.1.1 => 4.1.1
Expo Workflow: managed

you can run expo build:ios --skip-credentials-check to work around not being able to authenticate with apple through your machine, assuming the credentials are already configured for your app. i’ll let others comment here with suggestions on how to debug the underlying issue further

Good workaround, that did the trick. Curious to understand what’s happening with the credentials though. Anyways, thank you!

I am experiencing the same issue as well. Started today for me.

try setting these environment variables to gather more info:


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.