Build:ios gives an error!

Hello everyone!

I tried to build one of my apps for iOS but I got an error. I get the error right after I filled in the login details for my Apple Developer Account, this is the error:

Authentication with Apple Developer Portal failed!
/usr/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-linux/traveling-fastlane-1.9.11-linux-x86_64/authenticate exited with non-zero code: 1
Error: /usr/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-linux/traveling-fastlane-1.9.11-linux-x86_64/authenticate exited with non-zero code: 1
    at ChildProcess.completionListener (/usr/lib/node_modules/expo-cli/node_modules/@expo/spawn-async/src/spawnAsync.ts:65:13)
    at Object.onceWrapper (events.js:286:20)
    at ChildProcess.emit (events.js:198:13)
    at ChildProcess.EventEmitter.emit (domain.js:448:20)
    at maybeClose (internal/child_process.js:982:16)
    at Socket.stream.socket.on (internal/child_process.js:389:11)
    at Socket.emit (events.js:198:13)
    at Socket.EventEmitter.emit (domain.js:448:20)
    at Pipe._handle.close (net.js:606:12)
    ...
    at spawnAsync (/usr/lib/node_modules/expo-cli/node_modules/@expo/spawn-async/src/spawnAsync.ts:26:19)
    at runAction (/expo-cli@3.0.4/src/commands/build/ios/appleApi/fastlane.js:16:28)
    at Object.authenticate (/expo-cli@3.0.4/src/commands/build/ios/appleApi/authenticate.js:15:46)
    at process._tickCallback (internal/process/next_tick.js:68:7)

The login details I used are the correct ones. It’s kinda important that I get a working build as soon as possible, can someone help fix this error?

As device I am using a Chromebook with the Linux support. Everything works, only this. Is this an error for using a Chromebook? (I hope not)

I hope that someone can help me! Thanks!

Could you run expo diagnostics and paste the output here? Also, make sure you’ve followed our Windows-specific instructions for building standalone apps:

Windows users must have WSL enabled. You can follow the installation guide here. We recommend picking Ubuntu from the Windows Store. Be sure to launch Ubuntu at least once. After that, use an Admin powershell to run: Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

Hi!

I’ve run the command, here is the output:

Expo CLI 3.0.4 environment info:
    System:
      OS: Linux 4.19 Debian GNU/Linux 9 (stretch) 9 (stretch)
      Shell: 4.4.12 - /bin/bash
    Binaries:
      Node: 10.16.0 - /usr/bin/node
      npm: 6.10.1 - /usr/bin/npm
    npmPackages:
      expo: ^33.0.0 => 33.0.7 
      react: 16.8.3 => 16.8.3 
      react-native: https://github.com/expo/react-native/archive/sdk-33.0.0.tar.gz => 0.59.8 
      react-navigation: ^2.18.3 => 2.18.3 
    npmGlobalPackages:
      expo-cli: 3.0.4

I don’t think I can enable WSL, because I’m not using a Windows device. I’m using a Chromebook, but Expo is running on Linux (which can be run officially on Chromebook, no crouton)

I hope you can help me! Thanks!

Can you try to run this command directly?
/usr/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-linux/traveling-fastlane-1.9.11-linux-x86_64/authenticate

Are there any more specific errors?

Hi!

I’ve run your command, this is the result:

/usr/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-linux/traveling-fastlane-1.9.11-linux-x86_64/lib/ruby/bin/ruby: line 6: /usr/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-linux/traveling-fastlane-1.9.11-linux-x86_64/lib/ruby/bin.real/ruby: cannot execute binary file: Exec format error
/usr/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-linux/traveling-fastlane-1.9.11-linux-x86_64/lib/ruby/bin/ruby: line 6: /usr/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-linux/traveling-fastlane-1.9.11-linux-x86_64/lib/ruby/bin.real/ruby: Success

Thanks in advance!

It seems that you have ARM chromebook and binaries provided in that package are supporting only x86 platforms. Currently there is no way to run this on your computer.

You’ll need to run first build on different machine to generate credentials and after that it should work ok on your chromebook too. You would need different machine either way because macbook is required to upload build to app store.

Hi!

Hmm, if that’s the problem I can’t do anything about it indeed. I do have an Ubuntu device, but on there I have a different issue. I also created a topic for that (Expo isn't working) I can’t get Expo to work on that device. (that device isn’t ARM) Maybe you can help me with that problem too!

Aaahh, so if Expo is going to work on Ubuntu I can build an app for the first time there and after that on my Chromebook?

To upload the app to the app store I use an online service (https://www.wenz.io/ApplicationLoader) so that problem is already covered. :wink:

If you can help me with the problem on my Ubuntu device too that would be great! Than both problems would be solved :smiley: Thanks!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.