Attempting to call JS function on a bad application bundle

One of my users is cannot open the app after I updated the app with a minor change.

He is getting:

“Uncaught Error: Attempting to call JS function on a bad application bundle:

“Uncaught Error: Attempting to call JS function on a bad application bundle: AppRegistry.runApplication()”

“Uncaught Error: com.facebook.react.devsupport.JSException: Unexpected end of script”

This isn’t the first time an issue like this happened. This user was using the app perfectly fine prior to this minor version.

In the last version, same thing happened for a different user. I’m not sure if that user can use this new version yet.

This is a very serious problem for me because every time I release a new version, a new set of people cannot use the app. It just keeps not working for some people who were able to use the app perfectly fine.

Hey @saeho,

Can you provide us with the SDK version your app is running, what platforms are being affected and if possible a build ID for the affected build (if that’s not possible, a rough estimation of when you built the affected build)?


SDK version 32.0.0

Currently affecting a user with Xiaomi Android phone, forgot what model.
Unsure what Android phone the last user was using. I think Samsung for that person (don’t quote me on this info).

I seem to have less problems with iOS, there was one issue with iOS few months ago with assets, but I think that was my fault.

I built the affected build within ~24hrs of opening this thread.

I have an Android phone and I was not affected.

Android build id is 82 (I think that would be versionCode in app.json, correct?)

Also, the user was able to fix this issue by re-installing the app. However, not everyone is going to re-install the app when they face this issue, so ideally I’d like to find a permanent solution.

Tyvm for your help.

Hey @saeho,

By build ID I mean the the unique identifier that can be found by going to and selecting the build you recently uploaded to the store.

Would this be it? 8db89097-2e65-4bb3-a3ca-4f49da3dde40

Yep! Thanks for providing us with this info. I’ll let you know when we know more!

I have the same issue too

i’ve upgraded our app to sdk 32 because of google policies about SMS Permission

one of our clients reported an error like this

but strangely, it’s fine on my mobile phone. After i tested it again

i wonder what’s the problem

this is the build id

I got this problem too. Anyone have any ideas what the problems is?
Thank you

Hi! Did you fix it?
I have the same issue.

Does anybody have any ideas?

Same problems here when attempting to build standalone apps with the Expo build service.

Uncaught Error: Error calling AppRegistry.runApplication
Uncaught Error: Attempting to call JS function on a bad application bundle: AppRegistry.runApplication()
Uncaught Error: com.facebook.react.devsupport.JSException: Invalid character ‘\u001f’

Error calling RCTDeviceEventEmitter.emit
Unhandled JS Exception: Could not get BatchedBridge, make sure your bundle is packaged corrrectly

1 Like

I have the exact same error. Facing this on a xiaomi android phone. If anyone comes across a solution please do reply on this thread !

It seems that there was a problem in the “automized” build process of expo itself - for me it is working again this morning. For reliability purposes I’d suggest to turn OTA off for now. This might have caused issues on my end at least.

I have the same issue when building (partially)
It is not working on Samsung S10+, Honor 8, and 1 other android phones which I don’t know yet.
For me it looks like something during build process might be misbehaving…?
I’ll give it a shot to eject the app, even more because it seems not to be really reliable from what I can see in the former postings :frowning:

I have the same problem. Virtual device: Pixel API 26 / Andriod 8.0 / “sdkVersion”: “32.0.0”. Can I downgrade? I am very new to all this.

I am having the same problem on Android 9 Xiaomi A 2 with SDK 32. A few days ago, with the same settings, everything was ok: I changed icon and splash screen and rebuilt.
Any idea?

Same issue both on iOS and Android, broken even when reverting to the previous versions and rebuilding. Tried cleaning expo cache, node modules - nothing helps. I assume there might be an issue with the expo build system.

I am also having this same issue with my most recent build for the ios app store. Is there a solution?

I believe my build id is: 9fc4fce1-09b6-499a-8cbd-3f0544c5e925

I am also facing the same problem anyone who found the solution please let me know.

We are facing the same issue and its happening due to react-native maps. Does anyone have a solution, we might drop the idea of working on React-native.

@adamjnav Please help resolve our error.

Hi adam,
Have you found any solution for this.