SDK 36: Attempting to call JS function on a bad application bundle

After upgrading to SDK 36 (and upgrading expo-cli to 3.11.1), we’re unable to successfully launch our standalone Android builds. We receive the following error in the system stack trace:

Expo encountered a fatal error: Attempting to call JS function on a bad application bundle: RCTDeviceEventEmitter.emit()...

We’ve tried rebuilding multiple times. All builds result in the same crash on startup. Our test device is a Google Pixel 3a. The app runs as expected within the Expo Client.

This is the Android build number: 5a5f4406-ae3a-48cb-8e3e-160b82ac0c39

This problem has been reported for past SDK versions. Example, example, but not yet for SDK 36 to my knowledge.

Any other info we can provide to help diagnose?

This has been solved, but we’re unsure what the specific culprit was. We ran npm outdated and updated many of our old packages. Re-built and things worked as expected.

Perhaps npm didn’t update something properly when you upgraded. Glad got got it sorted out.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.