API response very slow (>10s) using Fetch or Axios in iOS Production only

SDK Version: 40 (Upgrading to 41 doesn’t resolve the issue)
Platform: iOS - Production only

My app is running well in development stage for both Android and iOS. When it’s set to production, only the iOS app is running very slow when fetching API. It takes more than 60 seconds to get just a simple test API. I tried changing to Axios with no effect. Strangely, it works well if I open the API in in-app browser or web view.

I am at loss whether the issue is at Front End level, Back End level, or server configuration.

(Production) API via Fetch or Axios ==> Response time > 60 s
(Production) API via WebView, in-app browser, and web browser ==> Response time < 2 s
(Development) API via Fetch/Axios/Webview/Browser ===> Response time < 2 s

Production server and development server is in different IP address but under the same domain name. The development is the subdomain address. Both using the same wildcard SSL.

No error in the log either.

Things we have tried:

  1. Commenting all console log
  2. Upgrading to SDK 41 from SDK 40

Things we are trying:

  1. Setting IPv6 to the domain address (but this can’t be done ASAP, and not sure why this could be the reason)
  2. Installing frisbee

Hopefully I could find some solution or direction where else to look. Thank you beforehand.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.