[2017-10-25] Issues with logging into Expo developer accounts

@bencodezen I’m really sorry about this problem. As a developer I totally understand that unexpected downtime and problems with platforms and services is disruptive and sometimes frustrating.

Our auth provider was able to restore accounts up to the last 24 hours (and we have our own backup for those 24 hours that we’ll attempt to apply) but we’re still seeing issues with the auth provider. Specifically, we’re checking both that they restored the data correctly and that the code that caused this data corruption has been fixed or rolled back. (We don’t want to re-enable logins and find that faulty code is corrupting the restored backup.)

If there’s any more information I can share that would be helpful please tell me.


@ide Thanks for all the updates.

When you say “we’re still seeing issues with the auth provider” does that mean for everybody or just for users with new accounts?

My account is definitely older than 24 hours and I still can’t log in via username, email, or Github.

Hi @ide Thanks for keeping us up to speed.
I’m sure you guys have access to this but this is the error I get:

I appreciate the quick response! It means a lot and I wanted to voice my concerns since I wasn’t sure if I was the only one impacted by this.

@javidjamae We’re seeing issues with all accounts, including our own.

Update: We just got off the phone with Auth0 and this is one of their highest-priority issues but we’re still seeing several problems with their API. First, we can’t log in with our own accounts: we get two different errors depending on the account – for some it’s a generic error that says “Oops, something went wrong” and for others the error says the username or password isn’t correct (and we’re pretty sure we typed in the passwords correctly).

Second, we’re currently unable to restore new accounts that were created yesterday. We have our own backup of those accounts but the auth service won’t let us recreate them since there’s some remnant of those accounts that wasn’t fully cleared.

Our priorities: Our top priority is to re-enable login for existing developers so everyone working on an Expo project can develop without --offline and publish their projects. Our second priority is to re-enable signup for new accounts and to email developers who created an account yesterday and might have had their account affected.

Next: As soon as we verify that the auth service has fixed the login issues and that existing accounts aren’t getting corrupted (we’re trying to avoid needing to request restoring from another backup, which would take several hours), Expo’s systems are in a state where we can immediately re-enable just login without signup and unblock everybody who already has an account.


Update: We are now able to access some accounts through our auth provider but not all. We are talking to the auth provider to understand what the root cause of this is and get to a place where we’re able to access all accounts created before yesterday without re-corrupting them.

Even though we have Investors meeting tomorrow, and it is very important for us to publish, I really appreciate your effort guys.

1 Like

Update: We are testing with our own accounts internally to make sure that logins are working. So far things are looking positive.


Happy update: We’ve re-enabled login for Expo developers. If you made an Expo account before yesterday, you can log into exp/XDE, https://expo.io, and the Expo client. All Expo services for you should work, including logging into exp/XDE, developing without the --offline flag, and publishing updates to your project. We’re really sorry about this unexpected issue and the extra stress from it.

Signups: New user signups are still temporarily disabled while we restore accounts created yesterday. We’re ready to do this on Expo’s side but are waiting for our auth provider to confirm they’ve fixed some database consistency problems regarding those accounts.


I’m trying to generate the APK and got:

exp build:android
[exp] Checking if current build exists…

[exp] No currently active or previous builds for this project.
[exp] API Response Error: Not authorized.

@zorobabel Can you try logging in again with exp login?

@ide exp login solved the issue

thx a lot!!!

I can not still login to Expo XDE.

Could you please share what error message you’re seeing? Try closing XDE and re-launching it and logging in again if you haven’t already tried that. If that doesn’t work, try closing XDE, deleting the .expo folder under your home directory, and then opening XDE again.

I am sharing my screenshot now… just strange…Screenshot_12

1 Like

When I run Expo XDE I get I’m unable to get past this form EVEN IF I FILL OUT ALL THE FIELDS. :slight_smile:

How long will it take for the too_many_attempts state to clear? I’d been periodically trying to login over the course of the day and now it looks like I’m still locked out of the IDE. I don’t want to keep trying if its just gonna reset that countdown timer : )

@faiwilsuc @remoteportal Hmm… did you log in with a username and password or with GitHub?

I deleted ~/.expo and STILL get the false positive message.

@cchoyce I’ll follow up with you out-of-band. We can unblock individual accounts but our auth provider doesn’t expose a way to do it across the board. We’ll submit a request for them to do that but let’s unblock you quickly.

1 Like