Still can't log in to Expo Go

I’m still getting “Your username, email, password or one-time password was incorrect.” when it isn’t. It’s been 12 days of trying to log in now. I’ve changed my password multiple times and tried uninstalling/reinstalling the app.

Have you tried logging in on expo using your browser at

1 Like

Hey @luk3r, in addition to captaineboy’s recommendation, can you try logging in with the CLI via expo login? If neither work, can you let me know if you’re using any network extensions or tools such as firewalls, proxies, etc.

Yes. Logging in on the browser (both to these forums and the main site) works fine

Yup, both work. Everywhere I can log in I am able to except for on the iOS app “Expo Go”.


I once had this problem in the past with Expo Go also.

Try installing Expo Go on a friend’s phone or on a different phone & log in to see if it works.

NB: Don’t send expo go to the person’s phone but rather install it directly from Google play store or the AppStore.

If this works, then you’ll need to delete Expo Go on your phone & clear the cache on your phone using any anti-virus app on your phone.

Now try re-installing the app from Google play store/ the AppStore & boom, problem solved.

Would be expecting your feedback.

Happy Coding

Thanks for the advice, I gave it a shot and no luck. Couldn’t log in on my friends phone either. It says “Must be logged in to perform request” when I try to hit log in

Did you download the Expo Go from Google Play store on your friends phone or you sent it to him through Xender??

App Store, no Xender. I’ve tried it on 5 more friends phones since, and it worked on 2/5. Though after logging in on those two and then even fully wiping my phone and trying again it still wont work on my phone. the two that it did work on hadn’t updated in a while, so I’m assuming it’s something to do with some api or something being blocked on new versions? Oddly the invalid credentials message is very rare now, and I almost always get “Must be logged in to perform request”. So yeh, seems like it posts the auth request which never replies for some reason but it still attempts to redirect to the account page or something, hence the “must be logged in…”

Android or iOS? What versions of Android/iOS?

I have an Android 9 phone that has trouble logging into development clients, I suspect it’s not related:

I am pretty sure that I have had login weirdness with Expo Go as well, but if I remember correctly it was more like I authenticated and did not get an error, but it was still showing as if I was not logged in. Then I think if I tried again or else closed and opened Expo Go it would at that point show that I was logged in. Sorry, I can’t remember exactly. And I’m not sure if this is related to what you’re seeing.

I don’t really know what you mean by “App Store, no Xender”.

I am guessing you are using Expo Go on iPhone.

I actually use Android & I knew immediately you asked the question that it had to do with the app.

I don’t really have much experience with iPhone, but I can tell the Android version would have worked after deleting, clearing the cache & re-installing it.

I think the solution now is for you to get the version from those 2 of your friends whose Expo Go version worked & use it for the main time.

Try rating the app on the store and let them know the problem you encountered.

Thanks again. Two of the five I tried were android, 3 iPhone, and yeah my phone is also an iPhone. We all had the most recent app version, when I mentioned versions earlier i was referring to ios/andriod versions.
But yeah, thanks for trying.

Yeah I doubt it’s related. I have an iphone and it simply wont authenticate, regardless of how many clients I have running. Thanks anyways