Your app currently targets API level 28 and must target at least API level 29 to ensure it is built on the latest APIs optimized for security and performance. Change your app's target API level to at least 29.

Today 04-08-2020, I build an app with sdkversion 36 and than update sdkversion to 38, as play didn’t accept my app. But After updating sdkversion to 38, the play store still not accepting my app.
Any solution???


I have been struggling with the same issue for two days, tried 36,37,38 no result…

I have same issue for one week, first with apple, and android.
Tried 38

Not to worry, after you have upgraded to 38 you should create a new build using expo build:android and all should be fine now, it’s been fixed

I build today, now successfully uploaded the Apk to Google Play.

Issue Resolved now 2020-08-05T18:30:00Z

problem fixed here :

How did you fix it? I have been having this issue for so many days now and I have tried everything.

Scroll up to the top of the page where the Expo team has posted a notice about this. I’ll post a screenshot here:

Thanks a lot! I didn’t think the problem was on the expo side, really thanks a lot for the info.

1 Like

Can someone please explain how to fix this instead of just saying “I fixed it” with no explanation. Thats very frustrating for others trying to upload an app.

1 Like

I still eject from expo and it is still targeting API level 28 instead 29. I have Expo SDK 38. Does someone know why it is still happening? Thanks!

@anickerson, The fix was done on Expo’s build servers. So you need to make sure you are on SDK 38, and then you need to build your app again. That should do it.

@jharteaga, did you eject because of this issue? Or was it for other reasons? You should not eject in order to fix this problem.

I just republish and rebuild the project, that’s it.
After this upload that Apk file to google play, it will be fine.
Make sure to update SDK to 38.

I am still experiencing this problem, after updating to 38 and generating a new build (expo build:android).

npm list expo
└── expo@38.0.9

Updating the expo.sdkVersion in my app.json fixed the problem, noting here in case someone else has the same issue.

I had sdk 37, build the APK and got rejected with API level 28 Error. Then I ejected to bare ,build a new APK with expo build:android , but again got same response from google console.
As In feature I need some react-native plugins in my App ,so I would like to stick with bare workflow.
If any one can help , please guid me how do I upgrade my API level ? or the only way is going back to managed flow?
Just to inform , before eject I was at expo 37.

So , If anyone else like me here. I successfully pushed my app to play store.
First I was at expo 37 (got rejected from playsore) , ejected to bare (Got rejected again), from bare only ran expo upgrade and build with new sdk38, this time play store accepted it.
Thanks for your inputs.

Hi. It was not necessary to eject. Just upgrading to SDK 38 and rebuilding would have been sufficient to solve this problem.

Yes @wodin you are right . At first I thought bare would be SDK free , and it was suggested in expo docs that its batter to go to bare instead of SDK Upgrades, So I had ejected and then had to upgrade also to fix the problem.