WebBrowser crashing in Android standalone app

Hi all,

I’m using Expo WebBrowser in authentication with Auth0, and that part works ok. But inside the app, trying to open any weblink with WebBrowser crash the app. Standalone Android app simply restarts, opening in Expo app gives the error message:

To make things more confusing, iOS standalone app is working just fine, and Android also worked fine just couple of days ago (I can’t track what would have changed and caused this). Tried to update to latest environment, installed everything from scratch, etc. No changes.

App is called “YDIN” and available in Apple Store and Google Play, and in Expo. Opens WebBrowser in Profile->Academy->Trainings.

Any ideas?

Thanks in advance,

hi! sorry about this, we’ve resolved the bug internally and the release will be rolled out tomorrow. you can re-build and re-deploy your standalone app without updating the sdkVersion and the fixes will be included.

edit: when you see the sdk 18 release announcement on our blog – blog.expo.io – then you will know it’s ready to go. you can see the commit that fixes this problem here: Fix bug where opening WebBrowser after calling dismiss on it once bef… · expo/expo@0c00552 · GitHub


Yes can confirm that updating to new Expo 18 solved this problem. Thanks!

Hello i have the same probleme on android, works great on ios.

this is my stack

"color": "^2.0.0",
"expo": "^18.0.9",
"native-base": "2.2.0",
"react": "16.0.0-alpha.12",
"react-native": "https://github.com/expo/react-native/archive/sdk-18.0.0.tar.gz",
"react-navigation": "^1.0.0-beta.11"