Upgrading from Expo 32 to 33

I am having a lot of trouble upgrading from 32 to 33. So far, my steps have been:

  1. Following this: https://docs.expo.io/versions/latest/workflow/upgrading-expo-sdk-walkthrough/
  2. Deleting my android/ios folders and ejecting again.
  3. Following this: https://docs.expo.io/versions/latest/expokit/expokit/#upgrading-expokit

Now, when I try to build in Android Studio, I have a ton of compiler errors because “error: cannot find symbol class ModuleRegistryConsumer”. Google search does not seem to turn up anything useful. Did I miss any needed steps?


Have you tried cleaning the project and restarting android studio? I’ve seen a similar error message before and that ended up doing the trick

Unfortunately did not work. Any other solutions you can think of?

Having just gone through 32 to 33, and 33 to 34, I would heartily recommend creating a new blank project with expo init, ejecting it, and comparing it against your build.gradle, MainApplication.java and MainActivity.java files, and copying in your changes. 32 to 33 is a doozy, and there’s always been some differences in those files that haven’t been covered in the update instructions (I guess in theory those changes aren’t strictly necessary for upgrading, but…) I actually do this with most updates, though 33 to 34 was quite minor so it’s much less necessary there.

Hi @avi1234

Have you solved the issue?

The same issue happens for me when i try to run the app in the simulator,

Can You help me solve the issue, it will help me a lot