Unverified android app built with production profile installs expo app

I am publishing a new expo app and followed the instruction to manually upload first android build to the play console. The app was built using eas build --platform android with production profile. I uploaded the .aab to the internal testing successfully and followed the link to play store to install the unverified app on my device. On launching the app it opens expo app instead of my app. Not sure whether its because the app is not reviewed yet or some other reason.

Build profile in eas.json looks like this,

  "build": {
    "development": {
      "autoIncrement": true,
      "developmentClient": true,
      "distribution": "internal"
    "preview": {
      "autoIncrement": true,
      "distribution": "internal"
    "production": {
      "autoIncrement": true,
      "distribution": "store"

I have published native apps in past but working with expo for the first time.

Appreciate any help!

Hi @schoudhary

Do you mean when you tap on your apps icon it opens the Expo Go app or that somehow the Expo Go code is running instead of your apps code? Could it be a development client?

Could you post the production build profile from eas.json? I have a feeling you might have accidentally added "developmentClient": true there

Hi @wodin,

Thanks for the reply. Yes, it opens expo dev client instead of my app.

I have posted the build profile in the original question above. Production build profile doesn’t have "developmentClient": true and I can see its generates a .aab (instead of .apk) based on the "distribution": "store" config. I tried running it locally and using eas cloud but same result.

Is there anything else I should look at to identify the cause?

Hmm… that’s strange. I’m not sure what could cause that behaviour. Although this is the default, does it make a difference if you add "developmentClient": false?

Do you have an android directory in your app?

Found that it was expo cache picking up dev client and bundling it with the app in production profile. Clearing the caches resolved the issue.

Thanks for the hints!