Unable to use development build

Hi everyone,
I’m trying to setup an expo development-build to use native module but even tho I’ve tried following the docs to the letter, I keep having a “xcrun exited with non-zero code: 1” when it tries to install on the ios simulator.

I’ve followed the steps here
The build and the app archive download are sucessful but it won’t install on simulators.
I’ve tried different ones, but it keeps erroring ‘xcrun exited with non-zero code: 1’

Every other managed expo projects that I have work well on simulator and devices, although I always have to start twice for expo to launch correctly… this might be related.

Edit : the process does work when the build is made for a device

“expo”: “~48.0.18”,
“expo-dev-client”: “~2.2.1”
eas-cli 3.13.3
xcode 12.5.1
macOS Big Sur 11.1

Hope someone can help :slight_smile:

I looks like I have exactly same issue. Expo Go exists just after it’s opened on Simulator, so I went with instructions from Create a development build - Expo Documentation to create dev client build, but when it tries to install it on Simulator I get “xcrun exited with non-zero code: 1” - same as you. Erasing simulator doesn’t change anything.

I also tried build without developmentClient (like in Build for iOS Simulators - Expo Documentation) but the issue persists.

The very same app runs successfully on prod build, installed on real device through TestFlight. I wanted to create screenshots for AppStore through Simulator, as I don’t have direct access to that many devices.

I have no issue running “ordinary” react native app (without expo) on SImulator.

@perroudsky what do you mean by “the process does work when the build is made for a device” - were you able to run it on Simulator somehow?

1 Like

Hi @pmar, sorry just saw your post !

By “the process does work when the build is made for a device”, I meant that creating a development build for the device work, like here : https://docs.expo.dev/develop/development-builds/create-a-build/#create-a-build-for-the-device. There’s more instructions in the youtube video at the top of the page.

I’ve basically gave up trying to make it work on simulator for now :frowning:

If you ever find a solution I’d be happy to hear it!

Initially I couldn’t make it work on simulator either (using eas build:run -p ios). It might be due to running all of it inside docker container (I started from GitHub - sickcodes/Docker-OSX: Run macOS VM in a Docker! Run near native OSX-KVM in Docker! X11 Forwarding! CI/CD for OS X Security Research! Docker mac Containers.). So for my use case (making app screenshots on different devices) I turned into https://appetize.io, where I uploaded simulator build (tar.gz. file) generated by:

eas build --profile preview --platform ios

where build.eas has below under build key:

    "preview": {
      "distribution": "internal",
      "ios": {
        "simulator": true

And it worked there - I could launch my app on several devices and take screenshots. Then I tried to install the same app.tar.gz on simulator:

tar -xvzf your-app.tar.gz
xcrun simctl install booted <app path>
xcrun simctl launch booted <app identifier from app.json>

And it also worked (through Linux → Docker/Qemu → MacOS → Simulator → Expo app - pretty impressive, but slow :slight_smile: ). So the issue it didn’t work initially might be related to eas-cli.