Unable to run published app


For some reason I’m unable to run my published app. https://expo.io/@jamongkad/mobile, funny thing is, I have no problems running it on my local. This only happens when I publish the app.

I get the following warning…
“Module AppRegistry is not a registered callable module (calling runApplication)” (code 2)

Hi! Have you tried running your app locally in production mode? You can disable development mode in XDE from the gear icon in the URL bar, and exp using exp start --no-dev.

If you still can’t reproduce the issue, can you paste your babelrc?

Hi! So this is the contents for my babelrc file. Also when I disabled development mode I run into a new error which is “undefined is not an object(evaluating ‘ViewPropTypes.style’)”

While enabling development mode again, my app starts back up without much fuss.


  "presets": ["babel-preset-expo"],
  "env": {
    "development": {
      "plugins": ["transform-react-jsx-source"]

Any more help on this? I already upgrade my entire Expo stack to the latest and greatest version and still I keep getting the same warning.

hello! make sure to read the breaking changes in updates between your version you’re updating from and the latest version. or google the error that you see and it will tell you the problem. you can find the note about the error you mentioned above in the sdk22 release notes: Expo SDK v22.0.0 is now available | by Brent Vatne | Exposition

I already updated to SDK 23 and have followed all the instructions to the letter. Running my app disabling “development mode” still gives the “undefined is not an object(evaluating ‘ViewPropTypes.style’)” and publishing the app still gives the “Module AppRegistry is not a registered callable module (calling runApplication)” (code 2)

However enabling “development mode” the app runs flawlessly.

I fixed it. There was an errant NPM package I was using that was causing the undefined is not an object(evaluating ‘ViewPropTypes.style’) thus causing all the grief on publishing as well.

In my case the library appears to be react native itself (and other RN components).

“expo”: “23.0.0”,
“prop-types”: “^15.6.0”,
“react”: “16.0.0”,
“sdkVersion”: “23.0.0”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-23.0.0.tar.gz”,

In node modules (grep propTypes.style):
42: imageStyle: Image.propTypes.style,
47: textStyle: Text.propTypes.style,

521: style: Text.propTypes.style,

71: labelStyle: Text.propTypes.style,

They all seem to be calls done by RN, but RN is imported from the Expo archive.

Any idea how to solve this?

My bad, it was my code calling View.propTypes.style which has been deprecated.

Other calls to ‘any React Native Component’.propTypes.style are still fair game. My app works in production now.