Published Expo application crashed on Launch. “AppRegistry is not a registered or callable module”

hello ,
I find this issue was closed a months ago , but I am facing it now . There’s no particular solution here.
Please can anyone help me solving it.
I face this problem after I published my react native app on play store. viewing the error log gives me this errors:

1-uncaught error : Module AppRegistry is not a registeres callable module (calling runApplication).
2-uncaught error: undefined is not an object(evaluating 'f.primary).


1 Like

Bumping this thread, I just ran into the exact same thing. There is very little debugging advice I could find.

I tried expo start --no-dev --minify and it works fine; I also tried rebuilding it and adding a new version, still broken.

Everything works great in development.

Any thoughts?

Hey @razankiwan2 & @torq,

Are you projects standard or ejected Expo projects?



Hi Adam,

Ours is a standard project, I believe, although it’s compiled from typescript. We have a working app that is almost exactly the same.

Are there any debugging hints you could provide?



This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.