Unable to find expo in this project

I recently updated to the newest version (4.5.0) of expo-cli from around 4.3 and every time I try to start my project I get the following error:

Unable to find expo in this project - have you run yarn / npm install yet?
├─ action /usr/local/lib/node_modules/expo-cli/src/commands/start.ts:34:11
├─ /usr/local/lib/node_modules/expo-cli/src/commands/start.ts:135:22
└─ expo start /usr/local/lib/node_modules/expo-cli/src/exp.ts:350:7

I’ve uninstalled and reinstalled expo, updated core-js, gone back to old versions of the expo-cli, and cleared the cache multiple times. Nothing has worked so far! I read something about editing “environmental variables” but I don’t know how and I’m terrified to just break everything.

Expo CLI 4.5.0 environment info:
OS: macOS 10.15.7
Shell: 5.7.1 - /bin/zsh
Node: 14.5.0 - /usr/local/bin/node
npm: 7.12.0 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
CocoaPods: 1.8.4 - /usr/local/bin/pod
Platforms: iOS 14.3, DriverKit 20.2, macOS 11.1, tvOS 14.3, watchOS 7.2
Android SDK:
API Levels: 28, 29
Build Tools: 28.0.3, 29.0.2
System Images: android-28 | Google APIs Intel x86 Atom, android-30 | Google APIs Intel x86 Atom, android-30 | Google Play Intel x86 Atom
Android Studio: 4.1 AI-201.8743.12.41.6953283
Xcode: 12.3/12C33 - /usr/bin/xcodebuild
expo-cli: 4.5.0
Expo Workflow: managed

can you share your project or a reproducible example of a project where this is happening? it sounds like you don’t have the expo package in your project or you didn’t run npm install

I feel silly now. This is a project I’ve been building for over a year and never had a problem. I thought for sure I removed and installed the new version of expo but maybe I only did so for the new expo-cli. Regardless, installing expo 41 worked. Thank you!

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.