Tried to update my Expo Cli and got this error, ive tried npm install too.

Unable to find expo in this project - have you run yarn / npm install yet?

Diagnostics

Expo CLI 4.11.0 environment info:
System:
OS: Windows 10 10.0.19042
Binaries:
Node: 14.17.0 - C:\Program Files\nodejs\node.EXE
npm: 7.12.1 - C:\Program Files\nodejs\npm.CMD
SDKs:
Android SDK:
API Levels: 23, 26, 27, 28, 29, 30
Build Tools: 27.0.3, 28.0.3, 29.0.2, 29.0.3
System Images: android-23 | Intel x86 Atom, android-23 | Intel x86 Atom_64, android-23 | Google APIs
Intel x86 Atom_64, android-25 | Google Play Intel x86 Atom, android-26 | Google Play Intel x86 Atom, android-27 | Google Play Intel x86 Atom, android-28 | Google Play Intel x86 Atom
IDEs:
Android Studio: Version 3.6.0.0 AI-192.7142.36.36.6241897
Expo Workflow: managed

Try using npm install -g expo-cli@3.5.0 this worked for me, it may work … if you get this error when the node module is being refreshed

MyBalanceNow