Unable to download standalone apk file build using exp

I build apk with exp build:android command.
exp build:status gave me a link to the apk file but that link shows access denied
what to do

1 Like

try exp login to login again

do we run exp start and exp build:android on the same command prompt or different command prompt.

I’m experiencing the same issue, getting a 403(Forbidden) from the Amazon server.

AccessDeniedAccess DeniedA695883B271ADD93…

I’ve tried exp login a second time without success.

1 Like

I having been the same issue since yesterday, Kindly share if you eventually solve it

Anyone who’s having issues downloading their APK, can you please DM me the URL and I’ll look into it?

hi same issue for me… how can i send a url as DM for you/

@h_derakhshanfar see if there is a space in between the link ,
like find '%20’ in the link remove it and then try to download the file

@adhiman thanks for answer but there is not space :confused:
https://exp-shell-app-assets.s3-us-west-1.amazonaws.com/android/@h_derakhshanfar/swift-9033079f-95ed-11e7-ac54-0a

is it the complete link, because there is not .apk extension in the link

@adhiman yes it’s not compelete. thanks a ton!! i clicked on vscode terminal on this link and it skipe the extension.!

Hey i m getting this link after running exp build:android
it publish my solution to my expo account , and doesn’t get any link of my .apk
how to get this apk link Please help…

image

Hey, I’m also not being able to download the signed apk. I’ve built the stand alone app three times and nothing. Here are the links:

Built 1)
https://expo.io/artifacts/2c837cd0-7755-47c3-85b8-7d8f6962f615
or
https://exp-shell-app-assets.s3.us-west-1.amazonaws.com/android/%40josepaez_2/equitec-app-9cb59858093a4b6e80a5acb167bd808a-signed.apk

I would put the other links but since I’m a new user I can only do posts with a 2 links

Weird. If I click on your second link it downloads fine for me.

Wow, thanks for the info! That means there’s nothing wrong with the process, maybe it’s just a latency issue or something of that sort. Because I just tried clicking the second link a few seconds ago and still nothing. Would you mind sending me the file you got via email? I’ll send you my info via DM. Thanks for the help!:wink::+1:t3:

Thanks for the help wodin, I still as of this moment can’t download the apk from expo servers but I got your email and got the apk file, so I’m very grateful for your help. I really hope expo fixes this soon for future versions of apps I wish to publish but for now I’m just happy there’s a temporary solution. Would you mind telling which country or region your in? Maybe this can help expo to fix this problem in the future (I’m in Colombia, Latin America).

The file is served straight from Amazon S3, so I really don’t know why it’s not working for you. I am in South Africa.

What happens if you run the following?

curl -O https://exp-shell-app-assets.s3.us-west-1.amazonaws.com/android/%40josepaez_2/equitec-app-9cb59858093a4b6e80a5acb167bd808a-signed.apk

It does start the download but the speed starts to decrease till it reaches 0. Apparently looks like Amazon S3 issue, although I’m not sure the exact cause of the problem. I’ve tried on several devices, from several places, I’ve asked friends to try and download it for me and still nothing.

It looks like a sort of Net Neutrality block or something like that hahaha but the thing is it’s just with those links generated from Expo. I’ve downloaded movies, files, etc… from elsewhere and everything works ok hahaha.

Here’s a wild guess: Maybe you have an MTU problem. Or there’s a router between you and S3 interfering with Path MTU Discovery. This seems unlikely, but maybe it’s worth trying to reduce the MTU to see if that helps.

e.g. here is one guide for setting the MTU on macOS.

Someone else from South America was also having problems but says it finished downloading in 3 hours.