TypeError: null is not an object (evaluating 'nativeImagePicler.launchImageLibrary')

hello i have a problem with my expo app
the app was working before 2 days and suddenly the app cannot use “image picker” like it was
i trying expo image picker (that work before 2 days)
and now because this error i try the “react-native-image-picker” and it also not working and get the same error:
react native image picker : TypeError: null is not an object (evaluating ‘nativeImagePicler.launchImageLibrary’)

expo image picker : TypeError: undefined is not an object (evaluating ‘result.assets[0]’)

the code not change since then so its not the problem
i think its something about the sdk or module or build or some configuration of the expo (maybe i change and forgot to check)

  "expo": {
    "name": "lottery",
    "runtimeVersion": {
      "policy": "sdkVersion"
    "updates": {
      "fallbackToCacheTimeout": 0,
      "url": "https://u.expo.dev/292e68aa-3480-4c01-b697-6672a8d899fc"
    "slug": "lottery",
    "version": "1.0.2",
    "orientation": "portrait",
    "icon": "./assets/lottery-icon.png",
    "userInterfaceStyle": "light",
    "splash": {
      "image": "./assets/lottery-background.png",
      "plugins": [
            "photosPermission": "The app accesses your photos to let you share them with your friends."
            "android": {
              "enableProguardInReleaseBuilds": true
    "assetBundlePatterns": ["**/*"],
    "ios": {
      "supportsTablet": true
    "android": {
      "package": "com.liors.lottery.first.project",
      "versionCode": 3,
      "adaptiveIcon": {
        "foregroundImage": "./assets/lottery-background.png",
        "backgroundColor": "#FFFFFF"
    "web": {
      "favicon": "./assets/favicon.png"
    "extra": {
      "eas": {
        "projectId": "292e68aa-3480-4c01-b697-6672a8d899fc"

Do console.log(result.assets[0]) to see what it returns first before attempting to upload to storage. It is returning null or undefined maybe!

Are you running the app in Expo Go or in a development build?

If it’s Expo Go, then react-native-image-picker will not work, but expo-image-picker should work fine.

If it’s a development build then either should work fine, but you will need to create a new development build after installing expo-image-picker or react-native-image-picker.

hey thanks for the answer
i didnt understand you
i am using expo go for the development
first of all i talking about development (in the terminal hit npm start) and expo image picker give me this error

i didnt understand that you write "create a new development build after installing?

everthing work before 2 days and i make a 2 publish and its work (on google play the app working with the image picker)
but then something change i think with the expo configuration

give me a object with " LOG {“cancelled”: undefined}"


console.log inside your if stataement

if (!result.canceled) {

It doesn’t matter…
I get undifiend.
But you can still see the console log that i show you
You can see clearly that the object that i get is not what i supposed to get.
It dosent matter if its inside the if
It supposed to give me object with 6 keys
And i get only cannceld : undifiend
I know its because something about the expo
And not about the libary expo image picker because i didn’t change anything on this library code

yesterday it gave me the error but today in the morning i run the development server and its actually working as was before and i didnt change something.
Very weird
But thanks for everybody about the help!