The Distribution Certificate is no longer valid on the Apple Developer Portal

Expo CLI 3.21.5 environment info:
    System:
      OS: Linux 4.15 Ubuntu 18.04.4 LTS (Bionic Beaver)
      Shell: 4.4.20 - /bin/bash
    Binaries:
      Node: 13.8.0 - ~/.nvm/versions/node/v13.8.0/bin/node
      npm: 6.14.5 - ~/.nvm/versions/node/v13.8.0/bin/npm
    npmPackages:
      expo: ^36.0.0 => 36.0.2 
      react: 16.9.0 => 16.9.0 
      react-dom: 16.9.0 => 16.9.0 
      react-native: https://github.com/expo/react-native/archive/sdk-36.0.1.tar.gz => 0.61.4 
      react-native-web: ^0.11.7 => 0.11.7 
    npmGlobalPackages:
      expo-cli: 3.21.5
expo build:ios --apple-id REDACTED --dist-p12-path certificados/certificado-2020-distribucion.p12 --team-id REDACTED --no-publish --clear-provisioning-profile
? Choose the build type you would like: archive

Checking if there is a build in progress...

Configuring credentials for machi.linti in project machi
Fetching available credentials
Authenticating to Apple Developer Portal...
Authenticated with Apple Developer Portal successfully!
Using Apple Team with ID: REDACTED
✔ App ID found on Apple Developer Portal.
✔ Getting Distribution Certificates from Apple...
✖ The Distribution Certificate is no longer valid on the Apple Developer Portal
Failed to set up Distribution Certificate
Failed to prepare all credentials. 
The next time you build, we will automatically use the following configuration:

Project Credential Configuration:
  Experience: @machi.linti/machi, bundle identifier: REDACTED
    Provisioning profile is missing. It will be generated during the next build
    Apple Team ID: REDACTED,  Apple Team Name: ---------

Cannot validate uploaded Distribution Certificate
Error: Cannot validate uploaded Distribution Certificate
    at useDistCertFromParams (/home/federica/.nvm/versions/node/v13.8.0/lib/node_modules/expo-cli/src/credentials/views/IosDistCert.ts:681:11)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)
    at IOSBuilder._setupDistCert (/home/federica/.nvm/versions/node/v13.8.0/lib/node_modules/expo-cli/src/commands/build/ios/IOSBuilder.ts:187:9)
    at IOSBuilder.produceCredentials (/home/federica/.nvm/versions/node/v13.8.0/lib/node_modules/expo-cli/src/commands/build/ios/IOSBuilder.ts:268:5)
    at IOSBuilder.prepareCredentials (/home/federica/.nvm/versions/node/v13.8.0/lib/node_modules/expo-cli/src/commands/build/ios/IOSBuilder.ts:140:7)
    at IOSBuilder.run (/home/federica/.nvm/versions/node/v13.8.0/lib/node_modules/expo-cli/src/commands/build/ios/IOSBuilder.ts:57:7)
    at IOSBuilder.command (/home/federica/.nvm/versions/node/v13.8.0/lib/node_modules/expo-cli/src/commands/build/BaseBuilder.ts:27:7)
    at Command.<anonymous> (/home/federica/.nvm/versions/node/v13.8.0/lib/node_modules/expo-cli/src/exp.ts:80:7)

How can I fix this error?

2 Likes

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.