The asset catalog at'payload/' cant be read


I tried to upload ipa file using application loader v3.0. But i got below error in application loader.

1 package(s) were not uploaded because they had problems:
/var/folders/h7/2f8lxrbj3dg4wlzyxmx6pwx80000gp/T/224F3607-CCAA-4706-B658-2C3779F25906/1252973135.itmsp - Error Messages:
ERROR ITMS-90596: “Invalid Bundle. The asset catalog at ‘Payload/’ can’t be read. Try rebuilding the app with a non-beta version of Xcode and submit it again.”

The build i tried to upload: Build ID: a2dfb7a8-df2d-46df-b894-ce8b726de45a

I have already a version 1 app in the app store. Now i tried to upload version 2 build by expo. Is this problem or any other. Please help.

Hi, can you update to the newest non-beta Application Loader? They are on at least v3.6. Let me know if the error still happens after updating.

Hi Ben,
Now I am using application loader v3.6. It is working. Thanks.

@ben I have this same problem, I am using application load v 3.7.1

The SDK of my apps are 29 and 31 respectively.

1 Like

I’ve experienced the same issue, updating to the latest version of Xcode as well as updating the Application Loader solved the problem for me.

Updating Xcode fixed this for me

Same error, but updated xcode didn’t fix the error.

Hey @arysoc,

What version of Xcode did you update to?

Which version of Xcode did you update to?
I have the same error and would like to know which one to use

I’m getting this error now when uploading something built using the Expo online builders. Uploading using latest updated fastlane.

@josh-es @omorhefere

What version of XCode is that? I’m on MacOS Sierra 10.12.6 and am on a work laptop that cannot be updated immediately.


I’m also getting the same issue using the same build method. From the other two posts, I’m not understanding how updating XCode helps if the builds are all being done by Expo Servers?

From the other two posts, I’m not understanding how updating XCode helps if the builds are all being done by Expo Servers?

Weird but I can confirm that it works after updating both MacOS and XCode. I’m using the Expo online builders and Fastlane to upload, with SDK28, and it didn’t work until I upgraded (unless the online builders have been fixed in the last few hours).

@mlight what version of XCode and MacOS?

XCode 10.1, MacOS 10.13.6. This is working for me using fastlane to upload.

Nevermind I was able to update to XCode 10.1, MacOS 10.13.6 and this fixed my issue. Thanks!

@adamjnav does expo build:ios commands use xcodebuild under the hood?

Hi Ben,

Can i ask how i go about updating the application loader? Do i have to update xcode, or can i update application loader on it’s own?