error in apple store while uploading IPA file

i built the ipa file with expo build:ios and tried to upload on apple developer center, but got error like this:


i am wondering if someone else has seen same issue. i did most of the work on the project using my windows pc. i am wondering if that has anything to do with the error i am getting. my understanding is build is hapenning on expo servers so this shoudl not be the issue but want to make sure.

also once you get the ipa file, can we just install it on iphone like we can install the apk files on android.

Hey @manishshukla,

Can you let me know what SDK version your project is and what platform you used to deliver the binary to App Store Connect? Here’s a stackoverflow post where others encountered the same error:


thanks Adam. i was able to submit with really no changes. i had used someone else’s machine to submit the app last time. not sure why that woudl cause issue but at that time my mac had a power cord situation so i borrowed someone’s laptop to just submit. when i got my own mac, it worked fine. :slight_smile: weird. its the same ipa file that i got from expo builds. anyways that problem is resolved. now i have a different problem that my app is not working in expo on my mac. i think it works fine in my windows machine. in my windows also i used WSL 2 to work.

Interesting. It certainly seems odd that changing laptops would enable you to submit. Regarding the new issue, would you mind creating a separate topic for that? (If you haven’t already)

We try not to have topics have sub-issues. Having separate issues allows for others to more easily search and find errors they may be running into.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.