StoreReview.requestReview() not working

Please provide the following:

  1. SDK Version: 39
  2. Platforms(Android/iOS/web/all): Android

I just upgraded to the sdk 39 and the requestReview() is not working anymore. It was working on SDK 38 tho.
The function isAvailableAsync() returns true and storeUrl() also returns the correct URL provided in the app.json. I also made sure that the URL is working.

It neither works in the expo app or a standalone built app.
Is there anything that I am missing?


Same here, upgraded to 39.0.4 and still broken, even with appStoreUrl and googlePlayUrl given correctly, isAvailableAsync() returns true, but no display screen is showing. Any news or workaround?

Hey, sorry for the late reply but I think I figured out what happens:
Since I already reviewed the app it wont show the dialog. But when I tried it on a phone where the app wasn’t reviewd yet it worked properly.
Maybe this is the intended behaviour? The documentation is pretty spare on this tbh.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.