StoreReview.requestReview is not working in Android in SDK 41

  1. SDK Version: 41
  2. Platforms(Android/iOS/web/all): Android 8+

StoreReview.requestReview() is working randomly on Android. It works on iOS.

We’re using only real devices to test, as we know it must have PlayStore installed. We used 3 different Android devices to test.

  • It never worked in Expo Go;
  • If we manually install a standalone build using adb install, it worked ONCE in device A, but never again; in the devices B and C, it never worked;
  • After we published to the Play Store (in production), we managed to get it to work in device B; however, devices A and C never saw the prompt.
  • StoreReview.isAvailableAsync() always returns true in the devices;
  • StoreReview.hasAction() always returns true in the devices;
  • We have StoreReview.storeUrl(); filled up (so android.playStoreUrl in app.json is filled up with a correct link to our play store page)

All Androids have at least 8.0+ installed.

Our code is very simple:

import * as StoreReview from 'expo-store-review';
static async askForReview() {
    if (await StoreReview.isAvailableAsync()) {

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.