Starting project with froze

I sucesfully installed all programs, then expo cli works well after restart computer still have error after start, can You help mi with direction where can be problem. Today I reinstaled (node, npm and al dependancies)

Thank You

Expo CLI 3.4.1 environment info:
OS: macOS 10.15
Shell: 5.7.1 - /bin/zsh
Node: 13.0.1 - /usr/local/bin/node
npm: 6.4.1 - /usr/local/bin/npm
Android Studio: 3.5 AI-191.8026.42.35.5900203
Xcode: 11.1/11A1027 - /usr/bin/xcodebuild
expo: ^35.0.0 => 35.0.0
react: 16.8.3 => 16.8.3
react-native: => 0.59.8
expo-cli: 3.4.1


@ start /Users/marianpatak/Documents/DEVELOPER/VUE-development/helloworld
expo start

Starting project at /Users/marianpatak/Documents/DEVELOPER/VUE-development/helloworld
(node:782) UnhandledPromiseRejectionWarning: RangeError: “port” argument must be >= 0 and < 65536
at Server.listen (net.js:1476:13)
at /usr/local/lib/node_modules/expo-cli/node_modules/freeport-async/index.js:8:12
at new Promise ()
at testPortAsync (/usr/local/lib/node_modules/expo-cli/node_modules/freeport-async/index.js:6:10)
at availableAsync (/usr/local/lib/node_modules/expo-cli/node_modules/freeport-async/index.js:24:17)
at Promise (/usr/local/lib/node_modules/expo-cli/node_modules/freeport-async/index.js:37:23)
at new Promise ()
at freePortRangeAsync (/usr/local/lib/node_modules/expo-cli/node_modules/freeport-async/index.js:33:10)
at /usr/local/lib/node_modules/expo-cli/node_modules/freeport-async/index.js:43:18
(node:782) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 2)
(node:782) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

For some reason expo thinks that all ports are in use.

Try downgrading to expo-cli version 3.3.0 or 3.2.3. If that works, please report back here.

EDIT: Also, are you running any sort of firewall or antivirus on your Mac? If so, what is it?

@wodin I am having the same problem and downgrading to 3.3.0 or 3.2.3 and neither worked
and i am not running any firewall or antivirus

Are you running some kind of firewall or antivirus? If so, what?

Can you run the following:

netstat -p tcp -an | grep '\<19[0-9][0-9][0-9]\>'

and paste the output like this:


Active Internet connections (including servers)
Proto Recv-Q Send-Q  Local Address          Foreign Address        (state)
tcp4       0      0  *.64724                *.*                    LISTEN
tcp4       0      0     ESTABLISHED
tcp4       0      0     ESTABLISHED
tcp6       0      0  2601:681:203:7fd.63567 2001:470:1:791::.443   ESTABLISHED
tcp4       0      0          *.*                    LISTEN
tcp6       0      0  ::1.631                *.*                    LISTEN
tcp6       0      0  fe80::aede:48ff:.62603 fe80::aede:48ff:.51000 CLOSE_WAIT
tcp6       0      0  *.*                    *.*                    CLOSED
tcp4       0      0      CLOSE_WAIT
tcp4       0      0      CLOSE_WAIT
tcp4       0      0      ESTABLISHED
tcp6       0      0  2601:681:203:7fd.54434 2607:f8b0:4001:c.5228  ESTABLISHED
tcp4       0      0      ESTABLISHED
tcp6       0      0  2601:681:203:7fd.51100 2607:f8b0:4001:c.5228  ESTABLISHED
tcp4       0      0      ESTABLISHED
tcp4       0      0      ESTABLISHED
tcp4       0      0    ESTABLISHED
tcp4       0      0     ESTABLISHED
tcp6       0      0  fe80::aede:48ff:.50383 fe80::aede:48ff:.61000 ESTABLISHED
tcp4       0      0         ESTABLISHED
tcp4       0      0         *.*                    LISTEN
tcp4       0      0  *.57621                *.*                    LISTEN
tcp6       0      0  fe80::aede:48ff:.49158 fe80::aede:48ff:.52032 ESTABLISHED
tcp6       0      0  *.61500                *.*                    LISTEN
tcp4       0      0  *.61500                *.*                    LISTEN
tcp4       0      0      TIME_WAIT

No firewall or antivirus

There’s something weird going on with your grep command :slight_smile: But anyway, as expected it doesn’t look like you have anything listening on port 19000, and even if you did, you don’t have anything listening on all ports from 19000 up to 65535.

Try opening two Terminal windows. In one, run the following:

ruby -e 'require "socket"; server =; sleep(60)'

In the other, run:

netstat -p tcp -an | grep LISTEN | grep 19000

The ruby command should not give you any error messages or other output. It will stop running after 60 seconds.
The netstat command should give you the following:

$ netstat -p tcp -an | grep LISTEN | grep 19000
tcp46      0      0  *.19000                *.*                    LISTEN

Yeah i was so glad to find someone else with the same problem i thought i was just crazy since i couldn’t get it to work.

tcp46      0      0  *.19000                *.*                    LISTEN

So i took my laptop into work today and it ran fine… I’m so confused so i will try taking home and see if something i tried last night fixed it or if it has something to do with the network I’m on because i was having the same problem at a buddy’s house

OK, so you did not get any error from the ruby command?

Very strange. That’s basically the sort of thing that expo is trying to do, so I don’t know why it’s failing.

So it has to be something with Wifi it worked fine while i was at work on that wifi and if i connect to my phone as a mobile hot spot it works just fine so i wonder if there is something with my router settings but I’m not sure where to even look for that. Thank you for trying to help me figure it out!

I found if i went to the Network tab and enabled auto proxy discovery it worked just fine for me for anyone that comes looking.

Weird, but glad you found a workaround.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.