SDK 32.0.0 error in hashAssetFiles.js on production mode

I have updated Expo SDK from ver. 30.0.0 to ver. 32.0.0. I followed the migration steps and everything worked perfectly. My final step was to test the application on production mode and here my problems came: I am using firebase for user authentication and on development mode - I can log in, register and log out successfully, but on production mode, the following error appears when I try to log in by email and password:

I found that there is a new version of “expo”, so I updated my dependency in package.json to “expo”: “32.0.6”, now the error is the same but on a different line:

If I disable the production mode - everything works fine :confused: Also, I tried to build an APK and unfortunately, my build is also broken :confused:

The method that I am using is:

import firebase from 'firebase';

firebase.auth().signInWithEmailAndPassword(email, password)

And here are some of my dependencies in package.json:

"expo": "32.0.0", // "32.0.6"
"firebase": "4.5.2",
"react": "16.5.0",
"react-native": "",
"react-navigation": "3.2.1",
"react-redux": "5.1.0",
"redux": "4.0.1",
"react-native-elements": "1.0.0",
"sentry-expo": "1.10.0"

In app.json the sdkVersion is 32.0.0;

I am trying to avoid the downgrade process to Expo SDK ver. 30.0.0. Any help is welcome :slight_smile: Thanks.

1 Like

Okay, I found the issue.

I had to update firebase to 4.13.0 or bigger version :slight_smile:

I hope this can be helpful for someone with familiar problem :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.