Request a Link -- Incorrect URL

Hey hey,

Learning about release channels right now, and successfully published my first to a specific release-channel. The published URL worked as intended in sending my desktop-browser to the release channel, but this URL is different from the URL sent to my android device via the ‘Request a Link’ section.

URL from expo cli:<code i’m not sharing>?release-channel=abcd-test-release-1

URL sent to Android Phone from browser:
exp://<code i’m not sharing>?release-channel=abcd-test-release-1

The issue here being the latter (sent to my phone) does not register as a link to Expo client app (compare prefix of both URLs), thus I can’t open the app on my device… I changed the link-URL to be exact to the expo-cli-URL, sent it to myself, and it worked perfectly in the Expo client, but I don’t have a way to get this URL unless I personally alter it myself.

I also tested this by sending to another device, iOS, and the same URL was sent, thus the messaging app is unable to send me to Expo upon press.

Am I missing something with ‘Request a Link’ ?
Is it simply that the URL sent to my device is incorrect?


Ps I’m aware I can use the QR code.

Hey @mbpeterson19,

I just tested this for iOS and received a URL with the exp:// prefix and it worked as expected (Prompted with “Messages wants to open Expo” at first and subsequent taps opened the Expo Client and loaded the desired experience). I need to charge my Android device to test, but I’ll get back to you on that. Out of curiosity, what version of the Client are you running?



Thanks for the reply adam,

I’m running 2.9.2 on an Pixel 2 XL…
The link I receive on this device, and on an iPhone 5s is not clickable. See screenshot for link.

Also, my CLI is running 2.6.4-alpha.0

I appreciate your support Adam,


I just sent the link to an iPhone XS, and the link did work. The phone is running of the client app.

The issue appears to be inconsistent across various devices…

Any more assistance?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.