"[react-native-gesture-handler] Seems like you're using an old API with gesture components, check out new Gestures system!"

Hello. I’m upgrading to SDK 45, and getting the warning above. I presume it’s to do with moving from react-native-gesture-handler 2.1 to 2.2.

There’s a GitHub thread here: V2.2.0 New Warning: [react-native-gesture-handler] Seems like you're using an old API with gesture components, check out new Gestures system! · Issue #1831 · software-mansion/react-native-gesture-handler · GitHub

What should I do?

Okay, it’s fixed already - someone released 2.2.1 a few hours ago to address this!

1 Like