react-native-gesture-handler error

SDK version: 34
How can I solve this:

Some of your project’s dependencies are not compatible with currently installed expo package version:

  • react-native-gesture-handler - expected version range: ~1.2.1 - actual version installed: ^1.3.0
    Your project may not work correctly until you install the correct versions of the packages.
    To install the correct versions of these packages, please run: expo install [package-name …]

Downgrading to version 1.2.1 will yield more issues.


1 Like

run expo install react-native-gesture-handler and it will install the appropriate version for you

also, sdk34 is not released yet ;O

Yes, it installed version 1.2.1:

PS G:\Expo\mobshed> expo install react-native-gesture-handler
Installing 1 SDK 33.0.0 compatible native module using npm.
npm install --save react-native-gesture-handler@~1.2.1

SDK33, sorry. I got confused because I just updated the expo app that mentioned sdk34 and received an expo-cli update (3.0.4) on my PC. My brain got over excited I guess… :0)

Thanks for your help!

See, that’s the error I get now:

Press ? to show a list of all available commands.
Logs for your project will appear below. Press Ctrl+C to exit.
Unable to resolve “./createNativeWrapper” from “node_modules\react-native-gesture-handler\GestureHandler.js”
Failed building JavaScript bundle.
Building JavaScript bundle [=================================================================================================== ] 99%

close packager, run expo start -c and try again

1 Like

Yes! Perfect!

Thanks, man!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.