Problem with Fire base push notification

Hi There,

As per the docs where I run exp push:android:upload --api-key in npm, I got the error message “push:android:upload” is not an exp command. See “exp --help” for the full list of commands. Please help how can I run the command.
Package version as follows
“expo”: “^26.0.0”,
“react”: “16.3.0”,
“react-native”: “~0.54.1”,

More information when I sending notification from fire base control no notification come up and status showing completed.

why push:android:upload command not found in expo?


What version of exp are you using? You probably just need to upgrade exp. Run npm i -g exp if you are using npm.

Hi Jesse,
Thanks for your reply. Now the push command is working but If I send notification from Fire base console (Screenshot by Lightshot), no notification come up in my real android device. Is there anything else which needs to be configure instated of


Hi! You’ll need to make sure you follow the Expo Push Notifications guide to send the messages. Are you using Expo’s HTTP API for notifications? It sounds like you’re trying to send them directly from Firebase’s console.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.