Problem validating app.json.Unable to perform cache refresh

After upgrading to expo version 3.28.2 from 3.28.0, I ran into a problem, and the project gives such an error at startup, after that I rearranged it to that version again, and now there are problems with the app.jason, what should I do in any case?

Warning: Problem validating app.json: Unable to perform cache refresh for C:\Users\User\AppData\Local\Expo\schema-39.0.0.json: Error: connect ETIMEDOUT

Hey @emi22878, can you try rolling back to 3.28.0 and see if the problem persists?

Hello, same problem bro. My friend has the same problem with

Can you solve this problem in a different way?

Please post your app.json in a code block.

i.e. paste it in, then highlight the text and click the </> button to make sure it’s formatted properly.

Doesn’t help, I honestly don’t know what to do

No, I mean I want to look at your app.json to see if I can see what is wrong with it. Please paste the contents of your app.json into a comment as text. You can obscure any info you feel might be sensitive.


or this settings?
He swears along this path, I honestly don’t understand what’s going on

Yes, like that, but I want the text. Giving me an image makes it much harder for me to check. I can’t run a JSON tool on it to see if there’s maybe an extra comma somewhere. With the image I have to look for errors manually. Also I can’t tell for sure if that stuff about “Initial commit” is actually in the file, or if your editor was just displaying that info when you took the screenshot.


“expo”: {

"name": "colege-project",

"slug": "colege-project",

"version": "1.0.0",

"orientation": "portrait",

"icon": "./assets/icon.png",

"splash": {

  "image": "./assets/splash.png",

  "resizeMode": "contain",

  "backgroundColor": "#ffffff"


"updates": {

  "fallbackToCacheTimeout": 0


"assetBundlePatterns": [



"ios": {

  "supportsTablet": true


"web": {

  "favicon": "./assets/favicon.png"




OK, so it looks like there’s nothing actually wrong with your app.json.

It seems that something is blocking access to port 443. Do you use a proxy server to access the Internet? If so, try setting the http_proxy and https_proxy environment variables to your proxy server.

Sorry, but how can I do this?

Could there be a problem with the firewall? I have disabled it everywhere

Do you have to use a proxy server to access the Internet?

no i don’t use a proxy



Is this at work/school? If so you could ask the IT department if there is a proxy server. If there is one, they should be able to give you the details and tell you how to set the http_proxy and https_proxy environment variables.

If you are able to use a VPN, you could also see if that allows Expo to work. If this does work, it is not a proper solution, but it might at least allow you to continue.

use NPM(

using expo start the program starts, but with npm start errors