Pod Install Error after detaching

After detaching my app, running pod install inside the ios directory returns this:

Analyzing dependencies
Fetching podspec for `DoubleConversion` from `../node_modules/react-native/third-party-podspecs/DoubleConversion.podspec`
Pre-downloading: `ExpoKit` from `http://github.com/donedgardo/expo.git`, tag `ios/2.1.4`
Fetching podspec for `Folly` from `../node_modules/react-native/third-party-podspecs/Folly.podspec`
Fetching podspec for `GLog` from `../node_modules/react-native/third-party-podspecs/GLog.podspec`
Fetching podspec for `React` from `../node_modules/react-native`
Fetching podspec for `yoga` from `../node_modules/react-native/ReactCommon/yoga`
Downloading dependencies
Installing Amplitude-iOS (3.14.1)
Installing Analytics (3.6.8)

[!] Error installing Analytics
[!] /usr/bin/git clone https://github.com/segmentio/analytics-ios.git /var/folders/48/ldn9nnlx7bnbg6m8ss2b84hr0000gn/T/d20171205-95902-1ficfq6 --template= --single-branch --depth 1 --branch 3.6.8

Cloning into '/var/folders/48/ldn9nnlx7bnbg6m8ss2b84hr0000gn/T/d20171205-95902-1ficfq6'...
warning: Could not find remote branch 3.6.8 to clone.
fatal: Remote branch 3.6.8 not found in upstream origin

https://github.com/segmentio/analytics-ios has no 3.6.8 branch.

Tried this https://github.com/donedgardo/expo/blob/master/ExpoKit.podspec#L23 with no success.

Please help, Thanks.

Removing Pods file and pod.lock resolved the problem.

Hi, I have met the same problem, but I still can not resolve it.

Pods file refers to the Pods folder?
pod.lock will occur when pod install succeed!

Could you please tell me how you resolved it?

Sorry for the late reply, I removed the folder and pod.lock
then on the ios folder in terminall i ran pod install

pod update

fixed it for me.

1 Like