Please Help on Error connectException failed, can't make init working.

expo error uncaught error java.net.connectexception failed to connect to exp://192.168.1.8:19000
(I know is old topic)
Hi guys, I’m new to use the expo 33 version. got java.net.connectexception error, using LAN. localhost: 19002 working fine.
I had read most “connect exception failed” related post search by google.
I run fresh init app under Powershell,
what I did:
disable firewall,
reinstall nodejs to v 12.7.0
update expo-cli to expo --version 3.0.4
set IP priority to 10 etc…
local network web http://192.168.1.8:19000 no connection.

anything else I need to install? I didn’t install Android Studio
anything else could be??

Thank you.

I AM VERY SORRY.

Fixed with [ Enable AP isolation ] disable

Please check your Router WLAN settings.
I spent 8 hours to starting new app.

1 Like

Thanks for posting the fix!

I’m having a similar issue and think your post might help. Can you explain the fix in more detail though? What does “Fixed with [Enable AP isolation ] disable” mean? What Router WLAN settings should be checked? Can you describe what the router WLAN settings were and what they got changed to in order to fix this issue?

I am not sure what setting @jerry007 was referring to, unfortunately, but there might be a setting that allows different wifi clients (e.g. your phone and your laptop) to connect to each other.

As a workaround you could perhaps try tunnel mode.

Having the same issue and just tried tunnel mode, still no help. :frowning:

Its simple. look at your emulator internet connection. its might be been airplane mode

hello. I have same problen. I fetch android folder with kit. Open this android project in Android studio. When i run build to emulators and real devices, i have this crash:
java.lang.RuntimeException: Expo encountered a fatal error: java.net.ConnectException: Failed to connect to /192.168.100.20:80
at host.exp.exponent.experience.BaseExperienceActivity$2.run(
BaseExperienceActivity.java:197) at android.os.Handler.handleCallback(Handler.java:790)

Please help.

sorry for the late reply, I been using another account.
for my experience
First, development under Windows is highly going to get crash, with emulators.
procedures
check your local network connection, firewalls in windows, Ports are opening for inbounds and outbounds, check the windows defense opening.
check your router setting, some model dose blocked PCs access to other PCs by ports internally as above is my case.

I no longer use that router, so, no idea what model number for the router.
that was the router

[[ The AP Isolation is a feature of wireless routers that enables you to create a separate virtual network for each wireless client that is connected to a network name or SSID. When this feature is enabled, all wireless devices in the network will not be able to communicate with each other, preventing unwanted hacking. ]]

https://www.linksys.com/gb/support-article?articleNum=135098#:~:text=The%20AP%20Isolation%20is%20a,each%20other%2C%20preventing%20unwanted%20hacking.

thanks

1 Like

I update my android studio and then created a blank new expo project and it worked.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.