PC Crashes When Closing Expo Server


Expo CLI 3.21.13 environment info: System: OS: Linux 4.4 Ubuntu 20.04 LTS (Focal Fossa) Shell: 5.0.16 - /bin/bash Binaries: Node: 10.19.0 - /usr/bin/node Yarn: 1.22.4 - /usr/local/bin/yarn npm: 6.14.5 - /usr/local/bin/npm Watchman: 4.9.0 - /usr/bin/watchman npmPackages: expo: ^38.0.4 => 38.0.4 react: ~16.9.0 => 16.9.0 react-dom: ~16.9.0 => 16.9.0 react-native: https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz => 0.61.4 react-native-web: ~0.11.7 => 0.11.7 npmGlobalPackages: expo-cli: 3.21.13

Whenever I use ctrl+c to close the development server, or if there is any error that would result in expo crashing my PC also crashes, and results in the PC restarting or a blue screen of death.

I have tried uninstalling expo via npm, and restarting my PC on numerous occasions. If there are any other steps that I could possible take that would be fantastic.

In addition, if any more information is required please let me know and I’d be more than happy to provide it.

Best wishes :slight_smile:

  • is this just started or did you have this problem for some time?
  • you might try apt-get update && apt-get upgrade maybe it’s some bug in ubuntu
  • do you use sudo with any of the expo/npm commands?
  • you might try installing node via nvm

Hi! I’ve had this problem since I first installed Expo to work on react native. I will try running apt-get update && apt-get upgrade. I also feel it is important to say that the linux it is running on is WSL.

I do not use sudo when I run the expo/npm commands.

I will try to install node via nvm.

ok, I didn’t realize it’s on windows.

You can try switching to WSL 2, unless you already use it in that case switch to WSL 1.
Also, make sure if system is updated

@giotedesco did you every resolve this? I am seeing this problem as well.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.