CLI Problem: Could not connect to development server.

I am having the blow error very other when working with the expo cli.

Then I often have to restart it completely to be able to work with it again.

expo cli version: 2.11.3 & also with 2.11.6
npm version: 6.7.0
node version: v11.6.0
OS: Mac High Sierra

I tried to run expo start -c and seems to not help much.

also tried this:

watchman watch-del-all

rm -rf /tmp/ metro-bundler-cache-* 

npm start -- -- reset-cache

rm -rf /tmp/haste-map-react-native-packager-*

Does anybody have suggestions?

Could not connect to development server.

Ensure the following:
- Node server is running and available on the same network - run 'npm start' from react-native root
- Node server URL is correctly set in AppDelegate
- WiFi is enabled and connected to the same network as the Node Server

__37-[ABI32_0_0RCTCxxBridge handleError:]_block_invoke

In the console I also see this:

- node_modules/expo/build/logs/LogSerialization.js:146:14 in _captureConsoleStackTrace
- node_modules/expo/build/logs/LogSerialization.js:41:24 in Object.serializeLogDataAsync$
- ... 9 more stack frames from framework internals

      throw er; // Unhandled 'error' event

Error: read ECONNRESET
    at TCP.onStreamRead (internal/stream_base_commons.js:162:27)
Emitted 'error' event at:
    at emitErrorNT (internal/streams/destroy.js:82:8)
    at emitErrorAndCloseNT (internal/streams/destroy.js:50:3)
    at process.internalTickCallback (internal/process/next_tick.js:72:19)

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.